Diesel Place banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,956 Posts
Discussion Starter #1
Well I just got my toy back from the dealer. On-going clutch noise and vibration led to flywheel diagnosis. It has just been replaced. I've only driven it a couple of miles back to the office but it seems to operate perfectly.



The new part number is 12582861. Can anyone check and see if this is an updated or different number than the original p/n? I would feel a lot better knowing GM had attempted to fix the problem. . .


BTW, I looked at the take-off flywheel
!! This thing is HUGE!! It must weight 4 times that of a normal flywheel. I checked it out but could not see any obviously damaged parts.


The truck has just over 37K miles and 1280 hrs.
 

·
Registered
Joined
·
12,004 Posts
That sucks...


How did it take a dump? I dont know about it being a new part...
 

·
Registered
Joined
·
1,956 Posts
Discussion Starter #3
The flywheel is part of the engine covered by the 100K warranty. I did have to pay 97$ due to the lift kit being in the way.


The throughout bearing rattled and grinded in low gear, particularly when downshifting. The tech examined the clutch and pressure plate and they were in perfect condition.


It never quit working though I think there may have been some minor slippage. It works and feels/sounds like a charm now.


The dealer thinks it may be a new part but didn't know. They did have direction from the regional service rep to replace it due to known failures. Took them a week to get the new parts in.
 

·
Registered
Joined
·
494 Posts
It is a new part # as of Nov. 03. It may be improved or they may have just changed the #. I will let you know as I have one ordered so I can dissasembe it and find out.
 

·
Registered
Joined
·
1,956 Posts
Discussion Starter #5
CPMac;


Thanks. I hope to hear it is actually a redesigned p/n or that the manufacturing process has been corrected/improved. . . I don't want to go thru this again . . .
 

·
Registered
Joined
·
1,556 Posts
Deadeye, It's nice to hear a regional rep is in the know. What size tires do you have? Nice to be informed if mine ever goes and the dealer blames larger tires. Ya never know.
 

·
Registered
Joined
·
1,956 Posts
Discussion Starter #7
Jeli;


I intend tu put 35" on but am running Lt265 now. The clutch and pressure plate were in like-new condition after 37K. The flexplate/flywheel issue is a design or mfg problem, based on what I have read elsewhere. Lots of folks running large tire with the 3.73 rear gear and no problems.


-D
 

·
Registered
Joined
·
1,956 Posts
Discussion Starter #8
I put new wheels and tires on (see sig). After the flexplate was replaced the clutch started slipping and the pedal got hard. Took it in today a the service rep called the reg tech rep . They are going to install an aftermarket mannual tranny cooler at no cost to me!! This should help the hard pedal. Doubt it will stop the slippage.


CPMac, did you ever obtain the new p/n for the new flexplate? Also, you were designing a new one or clutch. How is that going?
 
1 - 8 of 8 Posts
Top