Diesel Place banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,879 Posts
Discussion Starter #1
Pull up to my office gauge was just below half, go inside for 30mins, come back out start up my truck, fuel gauge is on empty and the dummy light is on, pull around to the fuel pump, top up the tank and restart the truck, it still showing empty:mad: , Now on my other truck an 02 LB7, the gauge read E and when I pulled the tank the little foam float was not attached, could this be the same probem, if it is it's going to be a PITA to fix:mad:
 

·
Registered
Joined
·
7,187 Posts
Mine took a dump too, it is good from full to just over 1/2 tank and then it goes crazy..........:rolleyes:

Looks to me like the sending unit is hosed.

I have been running by the trip OD for miles for the past few months, waiting for spring to swap it out.

POS !!!!!!!!!!
 

·
Registered
Joined
·
1,550 Posts
There goes a few hundred dollars. I had to change one in my dad's 99 Silverado doing the same thing.
 

·
Registered
Joined
·
1,879 Posts
Discussion Starter #4
Oh, now the story gets better! park my truck in the garage overnight( went down to -25) start up the truck fuel gauge works now:D but idling rougher than hell, scan it and get P0302 misfire on cylinder 2 :mad: So I let it warm up and little and restarted it a few times now the code is gone and it idles fine:confused:
 

·
Registered
Joined
·
483 Posts
Think that there is a TSB (recall?) on the Silverado sending units if I'm not mistaken...ya might get lucky and have the dealer fix it for $0.:beerchug:
 

·
Registered
Joined
·
38 Posts
Mine did some wierdness the other day too. I was close to empty so I filled up.
I know it was full, because i seen it the filler neck.

Get in to go and the gauge reads 3/4. Start to think that maybe it was just foam in the neck. I drive for 10-15 minutes and the gauge slowly crept up to the full mark.

I dunno, but I will have to keep an I on it I guess.

Later
Molsondrinkr
 

·
Registered
Joined
·
578 Posts
My gauge has been doing that since I bought it (two weeks ago). I just keep track of mileage and fill up after 200 or so miles. I'll take it to the dealer sooner or later.
 

·
Registered
Joined
·
32 Posts
you know what same thing here i need hepl with that tooo mine started with the fuel going crazy now the engine temp the tranny temp and the volts are going nuts too.
 

·
Bac To The Future
Joined
·
23,029 Posts
I've noticed that the cold temperatures are affecting my cluster....the stepper motor for the fuel gauge may be going out on you guys. (see all the "cluster problem" threads for more info on symptoms)

#2 misfire could be FICM wire harness. #2 and 7 are known problem areas.
 

·
Registered
Joined
·
3,903 Posts
uncle had same problem, come to find out the sending unit was broken. We superglued it back together(plastic part) and it worked ...........for a while until it broke again in the same spot.
 
1 - 11 of 11 Posts
Top