Diesel Place banner
1 - 20 of 25 Posts

·
Registered
Joined
·
716 Posts
Discussion Starter · #1 ·
So I spent the last couple of days Flushing my engine, changing the oil, new 40hp marine injectors, turned up injector pump all the way, 17lbs of boost MAX (guna turn the boost down a little), hooked up my lift pump, installed the gauges. And holy cow, I the power is absolute ridiculous!!! I had no clue it was going to be this much. The boost maxes out at 17lbs and the pyro takes awhile to get to 1000 degrees. I put on a fuel filter housing but when I turn off my truck the lift pump still goes for a little bit and the fuel filter is leaking fuel around the housing after I turn off my truck. I put on the new housing thinking it would solve this leak. But it didnt....any suggestions???
 

·
Registered
Joined
·
865 Posts
Make a 0-60 vid, I want to see a 6.5 with ridiculous power :cool:
 

·
Registered
Joined
·
618 Posts
Your leak may be one of the hoses around the filter canister, my lift pump also runs for about 5 sec after i turn the engine off. I had a similar leak problem, replaced all the hoses & filter canister and no more leak.
Don
 

·
Registered
Joined
·
901 Posts
mine leaked at the bottom oring of the filter can...replaced it and all is good...no leak

btw my pump runs till the oil pressure bleeds off
 

·
Registered
Joined
·
32 Posts
I don't believe this would be your problem but I had a similar experience with a fuel leak at the housing and after hours of chasing this one it turned out the little metal ring that holds the rubber seal at a 45 degree angle on the filter itself had stuck onto the housing and when I would change the filter, the new rubber seal would not seat properly. BTW, it didn't leak until I installed a new lift pump.
 

·
Registered
Joined
·
352 Posts
Just on an off chance, also check the hose that connects the t-valve at the front of the engine.

I had a leak off of the back of the motor that appeared to be the filter housing.

It turned out the hose on the t-valve was leaking ever so slightly and was tracing the hose all the way to the back of the motor and making a mess.

Chances are, thats not the problem, but it never hurts to check.
 

·
Registered
Joined
·
8,014 Posts
Replace all the hose, laying on top of the engine it gets hard, spring clips can't overcome the hardened hose and does not seal after a while, replace the hose & use "worm-screw" clamps. There is also a o ring for the WIF sensor and heater probe on bottom to have a look at, mite be a good time to do "feed the beast" mods
 

·
Registered
Joined
·
642 Posts
There is also a o ring for the WIF sensor and heater probe on bottom to have a look at, mite be a good time to do "feed the beast" mods
GM numbers are in the part point sticky.
 

·
Registered
Joined
·
2,885 Posts

·
Registered
Joined
·
4,854 Posts

·
Registered
Joined
·
647 Posts
That is a 6.5??? The spedometer goes up to 180?? Mine goes up to 100 I think.
 

·
Registered
Joined
·
911 Posts
That was damn impressive! Was that on ice or asphalt?
 

·
Registered
Joined
·
471 Posts
Maybe down a Canadian hill where they use KPH.:)
 

·
Registered
Joined
·
642 Posts
That is a 6.5??? The spedometer goes up to 180?? Mine goes up to 100 I think.

Look where he is located. I think the spedo is in kilometers.
 

·
Registered
Joined
·
363 Posts
MPH is the small #'s. You got kilometers per hour on your speedometer.
 

·
Banned
Joined
·
9,366 Posts
Aw, Damn, Edzed ... you let the cat outta the bag!

Now they're all think we ALL got km on our speedometers, when that 180 really means we go that fast! (To get to work...)
 

·
Registered
Joined
·
2,885 Posts
MPH is the small #'s. You got kilometers per hour on your speedometer.
yeah, i got kms on my speedo, but it's not my fault. 90% of the planet uses it. they probably also use imperial gallons which means we in Canada get 17 mpg before i did my latest mods in a dually. not sure on mpg as i have a heavy foot lately. will take some time getting used to the new computer before i can post new mpg. having read up alot of info on this site my next and last mod will be an i/c or w/m injection. Until the engine grenades on itself. then go internal. Ed
 

·
Registered
Joined
·
716 Posts
Discussion Starter · #18 ·
Well I have a 5sp and if there is a little sand or the road is a little moist I will break the rear loose in 2nd and possibly third so it would be hard for me to video it. I think a vid of all the smoke would be even better. I had cars get in the other lane when driving around omaha. I couldnt even see the front of their cars!!!:eek: Yeah I opened her up at 75mph last night and hit 18lbs of boost so I need to turn it down a little. I have 4:10s and only feel comfortable at doing 90 tops..................So back to the leak, would it just be easier for me to take the lower intake off, If I do I will be replacing all the rubber hoses down there and tightening the HELL out of all the clamps. Its a brand new housing so it shouldnt be leaking from the housing.
 

·
Registered
Joined
·
647 Posts
Haha KM's. Got ya. I feel pretty dumb. lol.
 

·
Registered
Joined
·
969 Posts
lol its alright
 
1 - 20 of 25 Posts
Top