Diesel Place banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey, I have been reading i the faq's section but no help yet.
I have a 93 3500 6.5 the motor had been pulled out replaced the crank with used one and one used piston. crank had been turned. wont start, we did manage to pull start it and had it idle for about one hr. New starter, 750 ccap. cleaned injectors. but no C,E,L. Please send help!!!!
 

·
Registered
Joined
·
6,945 Posts
Welcome to the forum christoph(er?)........

You truck is DB2 mechanical injection pump - you may have an Emissions Control Module, but no PCM with a manual trans.

Troubleshoot the Lift Pump system - see if it's getting fuel from the tank to the IP

IP timing may be off - exactly vertical is within time spec to start.

Rotate to driver's-side to advance timing, passenger-side to retard

HPCA terminal is on passenger-side - should have green wire from HPCA switch on passenger-side head, back of #8 exhaust port - orange wire there is switched Ign
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks!!! I am fixin to go out and check all that. The CEL does not come on at all. are you asking me if the wire to the HPCA is green or orange I don't quite understand> or are you telling me to check those two wires???
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
fingers are crossed

christophbower;1565604; said:
Thanks!!! I am fixin to go out and check all that. The CEL does not come on at all. are you asking me if the wire to the HPCA is green or orange I don't quite understand> or are you telling me to check those two wires???
Christopher Boweman is my name.
 

·
Registered
Joined
·
6,945 Posts
HPCA switch has two wires - orange Ign and green - green goes to Inj Pump terminal then to fast idle solenoid terminal
 
1 - 5 of 5 Posts
Top