Diesel Place banner
1 - 4 of 4 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have 05 Chevy Silverado 2500hd LLY turbo diesel more specific I bought the truck off. My former boss has the CTS to evolution deleted EGR street pipe exhaust MAF code 4 sensor has always been on same for a glow plug.
Same for wait to start lamp. Once upon a time, my friend always took care of all my car truck problems and needs like always.
Now that I got my first call truck, and the life blood of my brand new electrical company he has all that ruined me! I bought my truck to get my idol Arm or bar changed the steering was pulling that was five months ago that has still not been completed because when I drop the truck off he told me I had an oil leak.
FYI this is a month after he changed a bad injector. We have one rebuilt. Once he finished the gasket That night my truck broke down again. That was five months ago he keeps on claiming he knew what the problem was draining all my money, and each time did not fix the issue extending the amount of time that I have no work truck I’m on the brink of going under with the new company.
I’m out of money out of time , he claims he changed water pump all new fuel lines hoses, a new fuel pump that was two months old anyway before he decided to switch it out.
$1500 for CP three just the part. All these things claims all of the pressure in the lines is correct , it is exact same issue as from day one nothing has changed $4000 later.
Just in parts later five months later he is now telling me I need to PART MY TRUCK OUT!? The truck starts right away every single time. It will not go past 2000 RPMs in park neutral while you’re driving anything I’m pretty sure it’s in limp mode and whatever I’ve tried to get it out has not worked to this point.
P0089 fuel pressure valve performance code is the most relevant in my opinion I’m not sure can this have any bearing on limp mode?!
The truck runs fine other than not going over 2000 RPMs for only a short while before it starts making this horrendous, knocking, and all together terrible sound if I clear the codes out it will literally stop while it’s still running because they come up or injection harnesses.
Sometimes all the injectors themselves will come up. Does anyone have any clue I’ve checked wiring chat harnesses I’ve watched videos please help.
 

· Administrator
Joined
·
27,225 Posts
Welcome

Start by going through ALL grounds. Remove and clean the contact areas for each one.

Post the exact codes you are seeing with a scanner.
Inspect every inch of your engine harness looking for any rubbed through wire insulation, rodent damage, loose connectors or pins in the connectors.

The Duramax is known for wire harness issues
 

· Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Welcome

Start by going through ALL grounds. Remove and clean the contact areas for each one.

Post the exact codes you are seeing with a scanner.
Inspect every inch of your engine harness looking for any rubbed through wire insulation, rodent damage, loose connectors or pins in the connectors.

The Duramax is known for wire harness issues
 
1 - 4 of 4 Posts
Top