Diesel Place banner
1 - 2 of 2 Posts

· Registered
Joined
·
9 Posts
After a quick search across the ole interwebs, I found quite a few posts regarding the Cts2 causing almost every issue you're having. Try running 2-300 miles without the tuner plugged in and see what happens. I was surprised to read that it even caused A/Cs to not blow cold. It's more likely that you're having an issue with the Cts2 than it is you're having all of these wild and varying issues on the truck at the same time.
Hope it helps!
 
  • Like
Reactions: ryanschlegel5

· Registered
Joined
·
9 Posts
Sorry i have not responded to any of you guys, i have been extremely busy with work and school lol. and i never got a email saying i had a response. on my way to work the other day my cts2 was freaking out, pressing on the screen by itself, i mean so bad i unplugged it. while it was doing that it threw a “service 4wd” and acted like it was trying to go into limp mode. i finnaly got pissed off enough that i just unplugged it going down the road lol. as soon as i unplugged it, service 4wd went away and i have not had any issues since! i had read that the cts2 could be causing some of the problems but i was too ignorant and just immediately thought it was the remote starter. been 4 days with no cts2, and it has been running amazing! no codes, no problems at all. genuinely so relieved especially since i’m only 17 and have already had to dump my life savings into not only buying it but also having to put all new injectors in it, all i could think about was it being a bcm, or a ecm.. now my only worry is head gaskets lol. i run it on a tune that’s 5 horse under stock power and so it doesn’t open the egr valve lol. just hoping i never have to deal with those lmao.
Super stoked to hear it's running without issues now dude!
 
  • Like
Reactions: ryanschlegel5
1 - 2 of 2 Posts
Top