Diesel Place banner

1 - 8 of 8 Posts

·
Registered
Joined
·
275 Posts
Discussion Starter #1
I have a HS9500i that I'd like to put on my HD and was wondering if anyone else has done it and would like some suggestions. Thanks
 

·
Registered
Joined
·
1,242 Posts
15000lb with a trans4mer mount from WARN.


Check out the pics.
 

·
Registered
Joined
·
275 Posts
Discussion Starter #3
Looks great Gradyghost, is it pretty sturdy? If you dont mind me asking where and how mant beans did it set ya back?
 

·
Registered
Joined
·
1,242 Posts
Silvermax....Thanks for the compliment.....Its is one sturdy unit. There is alot of metal attached underneath. It hooks onto the frame and has cross members too. I have yanked out some heavy vehicles out of the mud. I have even pulled my own truck (with trailer attached) out of the mud. But mostly its used to pull other vehicles out of the mud.


I had to go to Jersey to locate the winch and mounting system(the 15000 was brand new and had to be special ordered and the trans4mer was reconfigured to fit the new style GM's in 2001) If you go to www.warn.com you can locate a local 4 wheeling store that will be happy to install and sell you the stuff.
 

·
Registered
Joined
·
612 Posts
Have the same winch on my truck as Gradyghost ... did choose a different cow catcher, mine is stainless with an additional bar in the headlight area .... have pulled some very heavy loads with it and she has handled them well .... Jim
 

·
Registered
Joined
·
275 Posts
Discussion Starter #6
Do you have any pics JEBar or a link that I could see it? I had a tranformer system a few yrs ago on my 1500 Z71 and it wasnt very sturdy and the brush guard around the headlights always worked loose and I had to retighten them all the time,when I used my winch it would move the whole assembly maybe they have done something differant since then.
 

·
Registered
Joined
·
55 Posts
I had a company truck in Texas that had the winch mounted on a receiver hitch. The truck had a trailer hitch mounted on both the front and rear bumper. The driver could mount the hitch at either end of the truck. Worked very well.
 

·
Registered
Joined
·
612 Posts
silvermax said:
Do you have any pics JEBar or a link that I could see it? I had a tranformer system a few yrs ago on my 1500 Z71 and it wasnt very sturdy and the brush guard around the headlights always worked loose and I had to retighten them all the time,when I used my winch it would move the whole assembly maybe they have done something differant since then.

Silvermax ...


Unfortunately I do not have the equipment to send/post pictures. If you will send me a PM with your address I will be happy to take a regular 33mm photo and mail it to you. My mount has been extremely stable, in over 40,000 miles I haven't had to retighten a single bolt.


Jim
 
1 - 8 of 8 Posts
Top