Diesel Place banner
1 - 11 of 11 Posts

·
Registered
Joined
·
369 Posts
Discussion Starter · #1 ·
Im lookin to put subs in my truck i just bought 2 10s Rockford fosqate there the P1 put them in my truck last night with a box i had it fit behind my back set. I have a cheep amp its a Jensen 500 watts I no they are not the best amps but they would run my 12s the speakers sound like crap is this becouse of the box or amp or speakers. I do have the Bose system my truck is a 04 lly crewcab..

1.What should i do get a new amp ?
2.Get a new box?

Please help.

Thanks. Mark
 

·
Registered
Joined
·
369 Posts
Discussion Starter · #2 ·
I talked to a guy a bestbuy last night he told me to get Alpine amp the mrp m350 they cost 199.99 is this a good kind i dont no much about all of this stuff or is there a better amp i can get for about that price. any one with any susguston thanks
 

·
Registered
Joined
·
369 Posts
Discussion Starter · #3 ·
any one?
 

·
Registered
Joined
·
9,606 Posts
I would go through you wiring first make sure your RCA are away from the power. Call an audio shop and see if there will test the amp for you. It could be the box too, are there any gaps in the joints is it solid?
 

·
Registered
Joined
·
4,722 Posts
How do the speakers sound like crap? Do they rattle? Whine? Gimme some help here.

Perhaps you have the amp turned up too high and the signal to the speaker is crap.
 

·
Registered
Joined
·
369 Posts
Discussion Starter · #6 ·
I would go through you wiring first make sure your RCA are away from the power. Call an audio shop and see if there will test the amp for you. It could be the box too, are there any gaps in the joints is it solid?
I looked over the box i can not find any gaps. i talked to bestbuy to day again they told me i can not hook up a after markit amp to my boss system so they must no much if ever one here is doing it
 

·
Registered
Joined
·
369 Posts
Discussion Starter · #7 ·
How do the speakers sound like crap? Do they rattle? Whine? Gimme some help here.

Perhaps you have the amp turned up too high and the signal to the speaker is crap.
No exotic noises lol, just seemed like some extra vibration from the speakers causing a little bit of a noise. kinda like hearing a little bit of plastic rattling and seems like they are not "thumping" like they should.
Very little "thumping" and I tried to re-adjust the amp and made sure all the wiring was good and just sounded like i really hadn't added the speakers to the truck- not much of a bass difference i guess.
 

·
Registered
Joined
·
4,722 Posts
How did you hook up the amp? Did you use an adaptor to the back of the stereo head or did you use speaker level out?
 

·
Registered
Joined
·
369 Posts
Discussion Starter · #9 ·
I think its a speaker level out. they guy at the speaker shop told me to hook it up at the back of the factory amp did i get the wrong part?
 

·
Registered
Joined
·
369 Posts
Discussion Starter · #10 ·
can some one give me some advice??? Im stuck dont no what to doo
 

·
Registered
Joined
·
9,606 Posts
Do you mean a Line Out Converter? If so that's where I bet you noise is coming from. Try the high level inputs on your amp first just like you wired the LOC.
 
1 - 11 of 11 Posts
Top