Diesel Place banner

1 - 19 of 19 Posts

·
Registered
Joined
·
278 Posts
Discussion Starter #1
i have noticed that when in kinda half on the pedal going, its seems to "bog" down or stall kinda then shift gears. its only the shift from third to forth gear. all others are fine. and at what milage should the " spin on"
tranny filter be changed? thanks for all your have.

06 cc/sb lbz 4wd
 

·
Registered
Joined
·
278 Posts
Discussion Starter #2
anyone???
 

·
Registered
Joined
·
278 Posts
Discussion Starter #3
wow. so no one knows the milage at which they change there filters, or when it should be changed. thanks lol:cool:
 

·
Registered
Joined
·
506 Posts
The initial filter change at 5000 miles or 200 hours. After that general service is 50000 mile intervals. For severe duty it is 12000 mile unless using transyd and the interval would be 50000 miles. I change mine around 5000 miles, I don't know why.
 

·
Registered
Joined
·
16 Posts
Mine has a soft, slipping shift into 4th until it warms up, even on a fairly warm morning. Even in tow haul mode it will do it until warmed up. In the winter time when it has been high idling I can get in it and it will not do it. Go figure!
 

·
Registered
Joined
·
278 Posts
Discussion Starter #6
thank you very much. i got a link to another website to order the filters from.
 

·
Registered
Joined
·
5,839 Posts
Josh change the spin ons every 5k...and i'll get you some spin ons...the alli dealer down the street from my office sells them to me for 8 bucks
 

·
Registered
Joined
·
892 Posts
ServiceOnSite,

Make sure your transmission has the latest program in it. There was a service release for 2006 that addressed a 4WD vibration but there was a 3-4 fix in there as well.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #9
was it in the glowplug recall program? i didnt get anything about the tranny
 

·
Registered
Joined
·
4,148 Posts
ServiceOnSite;1684856; said:
was it in the glowplug recall program? i didnt get anything about the tranny
Different one unless they did them both for you and didn't tell you.
 

·
Registered
Joined
·
16 Posts
Machinator, what did the 2006 service release update exactly?? Could this help my cold soft shift from 3rd to 4th?
 

·
Registered
Joined
·
10 Posts
I am working with gm rep on the very same problem now in fact he is coming to dealership on monday. Only does this in the morning i can update if we find anything.
 

·
Registered
Joined
·
892 Posts
Here's the bulletin. The 3-4 fix is not listed but was rolled into this update:

Allison Transmission - Vehicle Shudder When Driving in 6th Gear Range (Reprogram Transmission Control Module (TCM)) #06-07-30-013 - (05/30/2006)
 

·
Registered
Joined
·
163 Posts
I have the same problem (posted once or twice about it), Soft shift from 3-4 only when the engine is cold. Dealer has no idea, said "it was probably no big deal" "no codes, no fix". I will have to mention the 6th gear shutter fix. Thanks
 

·
Gone but not forgotten member
Joined
·
11,313 Posts
Mine has done the same thing. usually the first two times you go through all the ranges. It was terrible when I was running a power pup but is not near as bad with the EDGE.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #16
every time i go to the stealer they always are clueless. i get that how would you rate the dealer card from gm a few weeks later and neg them on the feed back and nothing ever happenes. it dosent just do it when its cold for me. it does it no matter what. cold, hot, towhaul, id like to take care of this soon i already have 17k on it.
 

·
Registered
Joined
·
10 Posts
That bulletin says nothing of the 3-4 shift problem and i find it hard to believe that the gm serv rep would not know that when we have been working on this problem for so long. I have talked to the gm allison rep my self.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #18
is there a service number on this????
 
1 - 19 of 19 Posts
Top