Diesel Place banner

1 - 4 of 4 Posts

·
Registered
Joined
·
206 Posts
Discussion Starter #1
I am in the middle of installing the 97 Cooling and a "F" Intake and I decided to pop the valve cover because I have this ticking noise on the drivers side. I thought it might be a rocker arm retainer but when I removed the valve cover all retainers are in place... Any ideas on what I could check to ensure the valve train is ok? Lifters? :confused:

I replaced the injectors on that side with some new Delphi's so I don't believe it would be the injectors... It is so tough to hear where it is coming from.

It is not the heater hose (replaced with rubber).

thanks for any help.

Rob
 

·
Registered
Joined
·
6,945 Posts
The heat shield on the turbo amplifies injector noise on that side.

Next time, place both hands firmly over the shroud, watch how the noise decreases.

BTW - replace the keepers while you got it open - original color is white nylon, and they disintegrate without warning as they brown from heat.
 

·
Registered
Joined
·
206 Posts
Discussion Starter #3
Thank you GMCTD. I will definitely check this out...
 

·
Registered
Joined
·
206 Posts
Discussion Starter #4
I found out that the little clamps that hold the pair of injector lines together was hitting the underside of the intake on one clamp and on another set of lines a clamp was hitting the block. I believe these were the culprits causing the ticking noise. I removed the clamps because of the interference and tied the injector lines together using zip ties over the rubber piece. I got them just as tight as the clamps were. I believe these should work. Definite noise reduction! Thanks guys..

Rob
 
1 - 4 of 4 Posts
Top