Diesel Place banner

1 - 4 of 4 Posts

·
Registered
Joined
·
620 Posts
Discussion Starter #1
No telling how long my vacuum pump has not worked...I suspect a few years. My question is...with the vacuum pump out this long, can this cause damage to the turbo? Or anything else? Dirty intake maybe?

I'm going to put in a new vaccum pump in the near future and was wondering if they are all the same? Any lifetime warrenties out there?
 

·
Registered
Joined
·
2,885 Posts
me thinks you'd have noticed long ago that the vac pump had gone. black smoke usually as it will not give you any boost with the vac gone. unless you went turbo master and dumped the vac connection
 

·
Registered
Joined
·
620 Posts
Discussion Starter #3 (Edited)
me thinks you'd have noticed long ago that the vac pump had gone. black smoke usually as it will not give you any boost with the vac gone. unless you went turbo master and dumped the vac connection
I do get the black smoke...and have for quite some time. I tested the pump awhile back and it was shot. The vacuum line is not even hooked up any more. I'm just wondering if this has caused any damage to the turbo...because it has been awhile.

There is a pretty big difference in prices for the pump $140-$250. I was just curious if it is "you get what you pay for", or are all the vacuum pumps prone to failure ...and it's just going to be a headache.

I have looked at the mechanical devices but have decided to go with a new pump for now.
 

·
Registered
Joined
·
2,885 Posts
try a search on ebay 4 one
 
1 - 4 of 4 Posts
Top