Diesel Place banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey guys! I just started hearing a grinding (almost like a bad bearing) noise coming from my turbo location when I turn the engine off. I have a 6.6l Duramax. It has not made this noise in the past 4 years that I've owned the truck. Has anyone had this problem or possibly know the problem?
 

·
Administrator
Joined
·
16,344 Posts
Welcome to DieselPlace
Please tell us more about your truck( Year, Make, and Model ) and list any known mods.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Welcome to DieselPlace
Please tell us more about your truck( Year, Make, and Model ) and list any known mods.
2011 chevy 3500 dually ltz 210k miles, full delete with EFI live. I bought it this way and its my first diesel truck so other than that I'm really not sure. I know the EFI is not turned up all the way if that makes sense?
 

·
Administrator
Joined
·
16,344 Posts
2011 chevy 3500 dually ltz 210k miles, full delete with EFI live. I bought it this way and its my first diesel truck so other than that I'm really not sure. I know the EFI is not turned up all the way if that makes sense?
Do you have any codes showing when truck is plugged into a scanner?
 

·
Registered
Joined
·
2 Posts
After I did my delete on my 2015, I had turbo "bearing" noise. What it was is the turbo housing wasn't completely seated. It went away when I jiggled everything into place a bit better and tightened the clamp a little tighter. Not sure if that is your issue but something to look at.
 
1 - 7 of 7 Posts
Top