Diesel Place banner

1 - 10 of 10 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hi all. I have seen a handful of old posts here about doing the turbo brake mod in the LMM so I figured I would try it on the truck I just got a few months ago. I set it up to a switch and when I turn it on it just puts the truck in tow/haul without the light coming in. Drops down a gear... But doesn't actually activate braking power. Any ideas what I did wrong? 2007.5 Lmm

Sent from my LM-G710VM using Tapatalk
 

·
Registered
Joined
·
16,213 Posts
Any way you can monitor the turbo vanes position?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
I don't believe so. It doesn't even act like the brake is on. Just downshifts like tow haul. Obviously not the normal let off the throttle and it kicks on when needed. I can go all the way down a hill and it won't do anything

Sent from my LM-G710VM using Tapatalk
 

·
Registered
Joined
·
2,533 Posts
Double check which pin you used to do the mod. And check to see if the circuit is activated when switched on. Did you also wire in a light to tell you when the brake is on?
 

·
Registered
Joined
·
4,089 Posts
Invest is A Edge Insight CS2/CTS2 to monitor lots of stuff including Turbo Vane Position.
What Ron said in #4, also have you tried engaging tow haul first before driving and keeping the rpms above 2000 to see if there's a difference.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
Yes and no difference. When I flip the switch on it instantly drops down a gear. Exactly what tow haul does. And when tow haul is on and I turn the brake switch on there is no change

Sent from my LM-G710VM using Tapatalk
 

·
Registered
Joined
·
16,213 Posts
Yeah. I think you need a Edge Insight to monitor vane position. Something isn't right but not knowing what the turbo is doing makes it harder to trouble shoot.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
I can monitor it with my snap on scan tool at work this week and see what's what. I read all the forums on how to hook it up and that's how I did it. Noticed when I turned the switch on the first time it instantly dropped a gear. Then realized it acted exactly like tow haul does. That would explain why there is no effect when tow haul is actually on. I'm positive I put it in the right pin slot too

Sent from my LM-G710VM using Tapatalk
 

·
Registered
Joined
·
16,213 Posts
Watch the vane position when you activate the turbo brake, I don't remember the speed you have to be at to make it activate so I would do atleast 60mph and then check turbo vane position.
 

·
Registered
Joined
·
2,533 Posts
I can monitor it with my snap on scan tool at work this week and see what's what. I read all the forums on how to hook it up and that's how I did it. Noticed when I turned the switch on the first time it instantly dropped a gear. Then realized it acted exactly like tow haul does. That would explain why there is no effect when tow haul is actually on. I'm positive I put it in the right pin slot too
Please tell us where and how you added your switch and ground for the brake Have you tested the switch with either a volt meter or test light?
 
1 - 10 of 10 Posts
Top