Diesel Place banner

1 - 11 of 11 Posts

·
Registered
Joined
·
379 Posts
Discussion Starter #1
I have a tst box I put it on my truck and it bucks really bad even in the low settings like level 3. I called tst and they told me that I needed a lift pump so I installed a holley blue.well the problem continued I called them back and they told me to check the fuel pressure to make sure the pump was not dropping under 4 psi checked the fuel pressure and it was at 12psi at idle and under power it would drop to about 6-7psi. my transmission has been done so it is not a trans issue.has anybody had these problems with this box? Edited by: Mackin
 

·
Registered
Joined
·
1,715 Posts
level 3?.......mine has three settings 80 /120 and extreme......Im not sure what you mean by "bucks really bad even in the low settings like level 3." Do you mean it bucks on the 80 and 120 settings? I have not had these problems just smooth shifting and power. Have you installed a guage where you can monitor the pressure while driving. Some regulators seem to restrict the volume. Just to make sure we are talking about the same animal you do mean Steve Coles Extreme from TTS and not the TST powermax? I did have similar issues with the TST comp early on but none with the tts ecm..........Diesel power and myself both have TTS extremes ecm and he runs a pumpsetup similar to yours Maybee he can help..........dave
 

·
Registered
Joined
·
494 Posts
I don't know what your problem is but 6 or 7 psi is plenty of fuel pressure so your problem is somewhere else. What I don't understand is why your blue pump will drop that much. Where are you testing fuel psi?
 

·
Registered
Joined
·
4,755 Posts
What I donot understand is who you are! You must be a troll, since you donot have a TTS Xtreme. I am the one that makes them and I also know who has everyone of them and you are not one of them! Since your talking about level settings beond what the product has maybe you have a TST box! If so please correct your post to the proper company.
 

·
Registered
Joined
·
6,063 Posts
I think you may be talking about a TST as i know the older comp version had some problems like you described, but i heard that was only on the highest levels and has since been resolved.


My TTS extreme doesn't buck like that. i run a holley black pump w/ regulator.


CPmac - i run the alcohol regulator and mine drops a decent amount under WOT. i've actually tried removing the regulator too, and it always seems to drop. i'm measuring from the test port on front of the engine. i can always maintain positive pressure, but it seems to like it better regulated as there is less change.. i think the more inlet pressure change on the HP pump the harder it has to work to manage output..
 

·
Registered
Joined
·
379 Posts
Discussion Starter #6
listen here I am new to the forum and I don t think you need to know who I am. I made a mistake it is the tst power loader the latest comp version they all sound the same to me ts,tts.tst I have so many it is easy to get it wrong especially late night. I was taking the fuel pressure from the purge screw on the the top of the filter housing.
 

·
Registered
Joined
·
12,262 Posts
600+duramax said:
listen here I am new to the forum and I don t think you need to know who I am. I made a mistake it is the tst power loader the latest comp version they all sound the same to me ts,tts.tst I have so many it is easy to get it wrong especially late night. I was taking the fuel pressure from the purge screw on the the top of the filter housing.

600+Duramax


You'll have to understand some ones lively hood is at stake and reputation ...


Not knowing if your familiar with competition in the BOX WARS but people will Troll and try make their competition look bad ....


Thanks for clearing this up Steve Cole (TTS) I'm sure is greatfull ...


I am going to edit your oringinal post as you have stated you have the TST Plug and Play box NOT the TTS Extreme Programer or ECM replacement ....


Thanks for understanding and welcome to the forum ....


Edited by: Mackin
 

·
Registered
Joined
·
4,755 Posts
Glad that this has been staighten out! One thing you should do is run each box by itself and see if the problem goes away, that is of coarse if you were stacking when you had your problems. The purge screw is not a good place to try and read fuel pressure, a better spot is to remove the factoy test port and tie into the rubber line that feeds the test port
 

·
Registered
Joined
·
379 Posts
Discussion Starter #9
I was not stacking when having this problem. This problem only happened when I would drive down the road not when I was on the dynojet dyno but even on the dyno I could not turn the power all the way up.The box by itself on power level 3 made around 440 uncorrected and it made 537 on pwer level 5 and the torque on level 4 stacked with the quad 215 but I could not turn it up anymore than level 5 and when I drove it on the street I could not even drive it with out stacking it on power level 1 before installing the lift pump after the lift pump I could only go to power level 3 without stacking.
 

·
Registered
Joined
·
1,715 Posts
thats what I thought.... tstEdited by: sdaver
 

·
Registered
Joined
·
448 Posts
When you figure it out let me know. Mine does the same thing, but not as bad as your's. Feels like it's running out of fuel, but I've been told by some knowledgeable people that's not it, but it's definately worse with a fuel filter that's a little old. I don't know the fix if there is one though. Currently I'm running on power 4 and Tq. of 3 (stock tranny and that's about all she'll hold, won't hold that in fifth though) and it'll only do it when the filter start's to have a little restriction.
 
1 - 11 of 11 Posts
Top