Diesel Place banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I’m hoping somebody can help me here as I am a bit stuck, I’ve only ever owned cummins and this is my first duramax and I am stumped. I have an 01 with 220,xxx. I put new injectors in and they have around 20k on them. A couple months back I drove the truck to work, shut it off, and it wouldn’t start again. Gave it a shot of ether and it started just fine. My CP3 psi was a bit low so I had a shop replace my cp3, and the truck still cranks but won’t start without ether (I know it’s bad for it) now when the truck starts with ether it runs and drives fine. No white smoke, drives like a brand new truck and will run fine all day, but the second you shut it off and try to start it, it will just continue to crank and not start. The injectors I last installed were around 5k and like I said only have 20,000 miles on them so before I jump right to that, is there something I can check or should start with? My balance rates are shown below. Any help is appreciated.
637685
6C191B24-7C4C-4094-86D9-F33B82A2000E.jpeg
 

·
Administrator
Joined
·
18,724 Posts
Welcome to DieselPlace

Start by replacing the fuel filter ( AC/Delco brand only) and pump up the filter primer button till it gets hard.
Let it sit (preferably overnight) and recheck. If the primer button is soft you have a leak/air intrusion in your fuel system and Usually, start with rebuilding or replacing the filter head..
 
  • Like
Reactions: Babin Farms
1 - 2 of 2 Posts
Top