Diesel Place banner

1 - 7 of 7 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
Ihave an 06 lly 6 speed
today my wife went to drive the truck and it acted as if it were cold. She didnt think too much of it until she tried to pull into traffic well it just revved up and would barely move so she pulled over and shut it down she thought it may have been the new edge evolution so she returned it to stock still nothing so she drove it back home a 1/4 mile or so and it had a hard time moving by the time she got to the driveway it would not pull itself up the driveway
so when I got home from work I tried to move it revs up fine but wont move in any gear . It will roll back in gear
Anyone have any Ideas it will be going to the dealer in the morning
Thanks for any replys
bil


Ps i have a 6inch tuff country lift 35 inch tires and the edge evolution
 

·
Registered
Joined
·
13,596 Posts
Try unplugging the edge and see what happens.Could the linkage be loose at the tranny?
 

·
Registered
Joined
·
91 Posts
Discussion Starter #4
I dont have any codes I took the edge out completly and checked the fluid level it was full but smelled real bad linkage is also good
 

·
Registered
Joined
·
91 Posts
Discussion Starter #5
well I took the truck to the dealer . It was a fried torque converter
oh well they are going to put in a new one
 

·
Registered
Joined
·
1,034 Posts
forkman;1585686; said:
well I took the truck to the dealer . It was a fried torque converter
oh well they are going to put in a new one
Did they cover it under warranty? The reason I ask, is the dealer by me is very strick on tires for the d-max. Everytime I go in there they look at my tires and say, " if anything drivetrain related goes out, you better put the 245's back on, or we can void warranty. " Bunch of BS if you ask me! So I have a set of stock wheels with 245's in garage just in case.
 

·
Registered
Joined
·
91 Posts
Discussion Starter #7
yes it will be covered under warranty as well as a new pump
 
1 - 7 of 7 Posts
Top