Diesel Place banner

1 - 11 of 11 Posts

·
Registered
Joined
·
16,971 Posts
Discussion Starter #1
I am thinking that the thermostat is either stuck or going bad. Truck never seems to get to normal operating temp of 190-200 like it is supposed to. Any other ideas? Truck runs fine, no codes and no other issues with fuel delivery or anything like that. Temps here have been in the 50-70 range so that would lead me to think that is it the thermostat, any other ideas? Getting ready to take it in to have it looked at but before I do just wanted to get any other ideas that may be floating around....Thanks

GMC2500HD
MOD
 

·
Registered
Joined
·
3,464 Posts
most the time i have to be really hard on mine to get it up to the 210 range. all other times it's hovering in the 170-180.
 

·
Registered
Joined
·
79 Posts
Temps

Mine will hardley ever go past 192 degrees even on days when it gets up 50 outside. BTW I am running the cover over the grill also.
 

·
Banned
Joined
·
6,540 Posts
Had any other things done to it recently?
Was it always this way?

180 is normal if it's not working. Ive seen 178 on the pred ECT reading, that is where my first stat is cracking intermittently.
 

·
Registered
Joined
·
488 Posts
Mine runs 177-183 on the scan gauge at temps anywhere from -15 to +50 with winter front anything above 50 and temps will increase to around 190
Merle
 

·
Registered
Joined
·
1,783 Posts
What temp is it running at. I live in So Cal ( another sunny location ) and in the winter I don't generally get to full temp, especially if its raining.
 

·
Registered
Joined
·
16,971 Posts
Discussion Starter #8
Well today it warmed up fine and it is in the low 50's here. I talked to a buddy of mine who is a GM mechanic and he is going to look at it when I take it in. He seems to think that it is the thermostat.. I will find out this week.
 

·
Registered
Joined
·
106 Posts
Even with my winter front on my truck wont get much above 180 even if im working it and its in the 40's. At least my trans gets to operating temp.....never seen my trucks coolant temps anywhere near 210.
 

·
Registered
Joined
·
40 Posts
My 04 took for ever to warm up in the winter. Then when it got to operating temp. it would cool off. It was allways going up and down till I put the winter front on.
 

·
Banned
Joined
·
6,540 Posts
Well today it warmed up fine and it is in the low 50's here. I talked to a buddy of mine who is a GM mechanic and he is going to look at it when I take it in. He seems to think that it is the thermostat.. I will find out this week.
Sometimes the ECT gauge fools. I notice this when datalogging. If the motor get to around 168, the gauge stays way back, when the stat finally cracks, there is little real change in ect but the gauge finally comes alive, moving to 200-210. A funny gauge.

You can test this yourself if you want. Run the motor till you get that 180 point, and feel the top rad hose near the stat housing (metal). Cool. Now run it harder, till that gauge swings over, and feel the tube. Hot. Stat finally cracked.

Could be related to an (insulative) air bubble in the housing where the sensor is. There is a bolt you can open to purge it. Hope that helps
 
1 - 11 of 11 Posts
Top