Diesel Place banner

1 - 19 of 19 Posts

·
Registered
Joined
·
2,161 Posts
Discussion Starter #1
Figured I'd post this here since I have the 85hp Predator tune installed... If you think it belongs in the LLY section, go ahead and move it...

I was coming up to a red light slowing down, and before I got to the light or stopped, it changed green. Foot off brake, on go-pedal, and BAM! Truck fell FLAT on it's face... almost like it stalled... jolted me forward a bit. then off it went. Anyone else had this happen? I've never had it happen before. No codes, either.
 

·
Registered
Joined
·
3,266 Posts
Sounds like it's injector time.. My LLY stumbles all the time.. Make sure you've got a good fuel filter in, and a lift pump sure helps.
 

·
Registered
Joined
·
223 Posts
3500 008 (Small).jpg Just posted today a similar problem after installing edge. if a lift pump is installed and mod is removed does the lift pump have to come out?
 

·
Registered
Joined
·
257 Posts
the bosch (sp?) common rail fuel system on our trucks is designed to have a lift pump before the cp3 but gm cheaped out. So yes you can leave your lift pump on without any other modifications.
 

·
Registered
Joined
·
2,161 Posts
Discussion Starter #5
Sounds like it's injector time.. My LLY stumbles all the time.. Make sure you've got a good fuel filter in, and a lift pump sure helps.
I'll check my balance rates again... just did a few weeks ago and they where fine... I think the worst one was close to 3 in P, which may not be great, but it's "within spec".
 

·
Registered
Joined
·
1,482 Posts
could it have been the tranny??? 85hp might be alittle much for a stock Allison
 

·
Registered
Joined
·
1,095 Posts
I was about to race a friend of mine this past weekend with my Edge on "stock" and when I was staging...just before I broke traction...just about to get into it...BOOM!!! The back of the truck was all torqued up then went down like a limp....! The CEL came on and could not go past 15 mph or shift out of 2nd gear until I turned it off, took the key out, opened the door to turn off all lights, then re-started it. It reset itself, but it is the 2nd time it has happend. Don't know what's up, but it sucked and I have been babying it since then.
 

·
Registered
Joined
·
2,161 Posts
Discussion Starter #8
could it have been the tranny??? 85hp might be alittle much for a stock Allison
I doubt it (but I could be wrong). I didn't get on it hard that time, and haven't had a problem since... and my balance rates are all ok.
 

·
Registered
Joined
·
334 Posts
Is it possible the tranny was in the middle of a downshift and made it feel like the engine stumbled. The predator does quite a bit of defueling which may have been all it was.
 

·
Registered
Joined
·
812 Posts
Sound's like a Fuel rail sensor.
 

·
Registered
Joined
·
2,161 Posts
Discussion Starter #12
I notice that your a long bed any chance you were at or below 1/4 tank of fuel?
Nope.... I was somewhere in the upper half... probably closer to 3/4 (over or under). Why?
 

·
Registered
Joined
·
6,210 Posts
The longer tank on a "long bed" allows the fuel to slosh farther away from the fuel pickup under acceleration and braking. I was just thinking perhaps you had an air pocket.
 

·
Registered
Joined
·
2,161 Posts
Discussion Starter #14
The longer tank on a "long bed" allows the fuel to slosh farther away from the fuel pickup under acceleration and braking. I was just thinking perhaps you had an air pocket.
I see.... but isn't there a baffle in there around the pickup to attempt to prevent that from happening?
 

·
Registered
Joined
·
6,210 Posts
The pickup sits inside a little cup with some one way valves in the bottom of it. Other than that it is wide open inside the tank. For pictures of the pickup assembly go to www.socaldiesel.com and scroll to the bottom of the screen or download the billet pickup instruction sheet for even more pics.
 

·
Registered
Joined
·
53 Posts
When is the last time you changed your fuel filter. I cant say for sure, but mine was having a similar problem and i removed the filter, and low and behold it was full of pollywogs. Just a thought......could be way off
 

·
Registered
Joined
·
7,187 Posts
Sounds like a 1093 to me.......I have logged a few LLY's and the rail psi is commanded at 23,000 PSI and it logs 9000-10000 PSI.

When it goes into limp it has a fuel limit table that drops the fuel to 1/10th and has no fuel over 2000 rpms effectively limiting power/rpm that way.

Find someone with a TECH II or EFI-LIVE and Log it.

I'll see if I can post a screen shot of it later,

T:D NY
 

·
Registered
Joined
·
2,161 Posts
Discussion Starter #18
A 1093 should show up with the DTC scan on the Predator, right? Because there where no codes afterwards.
 

·
Registered
Joined
·
2,161 Posts
Discussion Starter #19
Fuel filter is coming due soon... Checked my records and it has about 9K on it...

I've been thinking about primary filtration, possibly in the form of the Racor kit, and lift pump(s) since before I bought the truck... What's a decent, yet cost effective lift pump setup? Ideally, I'd like to try to stay inexpensive.

What's the best setup? Dual pumps in parrallel so if one fails, the other continues to work?
 
1 - 19 of 19 Posts
Top