Diesel Place banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Good Morning
I have a customer with a 6l90 in their ambulance. This is the second time in two months that the the bushing in the tail shaft housing has broken and pushed the seal out. I have checked for bad u-joints, bad trans/eng mounts even for broken cross members. Has any one else had this issue, what els could be causing this?
 

·
Administrator
Joined
·
18,984 Posts
Good Morning
I have a customer with a 6l90 in their ambulance. This is the second time in two months that the the bushing in the tail shaft housing has broken and pushed the seal out. I have checked for bad u-joints, bad trans/eng mounts even for broken cross members. Has any one else had this issue, what els could be causing this?
Welcome to DieselPlace
Have you replaced the driveshaft carrier bearing?
 

·
Administrator
Joined
·
18,984 Posts
It is a single piece drive shaft, no carrier bearing at all!
Tell us more about the ambulance ( Year, Make, and Model ) and list any mods
(y)
 

·
Administrator
Joined
·
18,984 Posts

·
Registered
Joined
·
985 Posts
Did you just visual inspect the u joints? They move freely and not binding?
Check the shaft for straightness? Maybe it got bent? You lube the splines on the trans output yoke? Does the trans output shaft move in and out at all?
And how exactly is the bushing 'breaking'? It's just a pressed in copperish bushing, right?
And you check the transmission fluid level? The fluid lubes that bushing.
 

·
Registered
Joined
·
3,843 Posts
Bent output shaft in transmission ?
 
1 - 9 of 9 Posts
Top