Diesel Place banner
1 - 13 of 13 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
Have a surging idle problem that started around 20k. Now have 75k. This is not the typical cold lopey idle and is actually worse at full engine and tranny temp. Most of the time it follows a consistent rhythm but can be erratic as well. It's bad (or strong) enough to lurch the truck if full brake pressure is not applied and is more noticeable if in gear. Sometimes it's bad enough that I've had people pull up next to me at a light thinking I'm trying to initiate a race.
Let's go! The truck runs out really strong and smooth otherwise.


Dealer has been great, and worked hard but can't pin it down. 7 months ago they replaced filter and 4 injectors. A few days ago replaced all 8 again. No change. They found a bulletin for idle surge and reflashed the ECM yesterday. No change. They've given up at this point. They claim pump and regulator check out O.K.


Any of you Diesel Wizards have any ideas?


Thanks,


Billy
 

·
Registered
Joined
·
692 Posts
ask what the pump ok ment......is hard to diag with out codes and data..if all 8injectors where replaced and the fuel filter all thats left is the pump which has the regulator attached and the fuel psi relief vlv. you say it comes and goes......stok air filter or k/n. had one onec that has a bad accelator pedel sensor....
 

·
Registered
Joined
·
11,645 Posts
I gotta lean on the fuel pressure regulator. Its the most likely cause to those that I have seen. Been replaceing them pretty regularly. Easy way to see it is using tech-2.. do a live plot of actual vs desired fuel pressure at idle and you should see a very smooth pattern, the two data lines should nearly lay on top of each other. A bad regulator will give the actual pattern a shark tooth over the smooth desired.
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #4 ·
Patrick & dmaxallitech,





Thanks a bunch for the input. Been out in CA to see my daughter and just returned. We'll see if the dealer can check out the regulator again as per your instructions.





Thanks,





Billy
 

·
Banned
Joined
·
2,067 Posts
Just out of curiosity, is the idle problem in park and neutral or only in drive gears?
 

·
Registered
Joined
·
11,645 Posts
greenlightening said:
same problem here. so i guess maybe there is no hope for a truck that just wants to go on it's own?
my truck also surges. getting worse by the trip.

sounds like you have a different issue, above is just a lopey idle condition


Bronco, most noticable on normal situations in park, just idleing
 

·
Registered
Joined
·
2,332 Posts
Mine had that problem, but Eric fixed it, bad fuel pressure regulator. It would idle funny and sometimes in gear, not enough to move the truck with the foot on the brake but you could see it on the tach and sometimes on the psi gauge.
 

·
Registered
Joined
·
114 Posts
i have the same problem on my 04 with lb7. going down the road and let off pedal the truck sometimes takes off for a second. when i first start truck up idles good and when i put in in drive/reverse trucks lunges and seems i'm giving throttle when my foots still on brakes. i thought my problem was with my edge. but it still does it.
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #10 ·
To All,


This is pretty weird. After my last post in February I've made two trips to California and back (3,200 mi per trip w no towing). It was so bad before the first trip another dealer was ready to put on a new regulator. After the trip the surge was gone. It began to come back again after 2,000 miles of mixed city & hwy. driving. Made the second trip and it went away again.


I'm beginning to think now it might be water or more probably air.


What do you think?





Billy
 

·
Registered
Joined
·
1 Posts
Hey guys, I have a 04 D/A, 9,500miles, I've been having the erratic lurching problem only when at a stop light, in drive, goes away when in park, also seems to blow some white smoke when this happens. dealer finds no problem, replaced the fuel filter, seems to be getting worse, is this the same problem, ??. I bought this truck off dealer lot in March ??,
 

·
Registered
Joined
·
1 Posts
Ditto with Camperguy, I am having the Idle problem only in drive and only in the morning after sitting all night when the Temp gauge is between 180 and 190 degrees, after it passes 190, the truck seems to smooth out. Dealer couldnt find any problems, ran diagnostics and checked for any software upgrades, none found. So at this point dont know what it is.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top