Diesel Place banner

1 - 9 of 9 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter · #1 ·
0. Describe in detail the problem you are having. Please be as descriptive as possible. -Cutting out sometimes when accellerating
1. Does the engine crank, or 'turn over'? -yes
1a. Does the engine start and run? -yes
1a1. If the engine does not start - Crack injector line: do you have fuel? Yes/No
1b. Do you have a Wait To Start Light & the amount of time (seconds) lit. -yes
1c. Ambient Condition (temperature outside indicate F or C) _doesn't matter____ °
1d. Engine Cranking speed (if you have an accurate tachometer).
1e. Are you experiencing stalling?-no
1f. If Stalling, describe (upon startup only, down the road, hit a bump etc)
1g. If Stalling, do you notice loss of dash or instruments?
-note if experiencing stalling,you must indicate PMD location in #24.

1h. Check turbo inlet and air filter for obstructions. Cone filters have lost disk and stopped air to turbo.
1i. In a no-hot start, pour a bottle of room-temp water on the injection pump. Does it start now? yes/no
1.1 Lift pump test - describe results-lift pump good​
2. Service Engine Light while running?- on/off/intermittent-only after it stumbles
2a. Service Engine light does glow during start/cranking/bulb check: Yes/No-yes
3. Model year -97
3a. Odometer reading (indicate if in miles or km)-111000 miles
3b. Miles on major engine components if been replaced (example Injection pump)
3c. Indicate the model number on the Injection pump (starts DS4 or DB2......)
4. Have you scanned for engine codes? (varies by pre/post 96) yes/no-yes
5. List exact results on engine codes: p0238
6. Air Filter condition (visual check)-good
7. Fuel filter condition (freshly changed/condition unknown/mileage since changed)-unknown
8. Condition of Battery terminal connections (removed, cleaned and tightened)-good
8a. Known condition and age of the batteries.-good 1 year
8b. Are batteries of differing age or are they a matched set?-matched set
8c. Condition of Major Grounds. (same drill as batt - removed, cleaned, retightened)-good
9. Upon cold start, does the radiator hose get hard quickly? Yes/no-no
10. Upon cold start, do you have excessive white smoke? Yes/no
11. Do you have excessive cranking time before the engine starts?-no
12. Have you used the block heater, and does this effect engine starting?(only try for starting problems)-no
13. During hard acceleration, do you have excessive black smoke? Yes/no-no
14. Do you have any unusual exhaust smoke issues?-no
15. Turbo check out - pass/fail
16. Do you have an EGR on the engine? (An F or an S engine code 8th VIN digit)-F no egr
17. Indicate if you know if it’s a 1500, 2500, 2500HD, 3500, 3500HD.-2500
18. Indicate fuel that you are using: Bio-diesel, #2 Diesel, #1Diesel, SVO/WVO, other-#2 diesel
18a. If running a VO (Veggie Oil fuel) setup, indicate details of your conversion (homemade, or packaged system)
19. Are you using any fuel additives? If so, please list.-2 cycle oil
20. Please indicate geographic region you are in: (example: Texas or Canada)-NC
21. Do you have any service history available that might pertain to the problem you are having?-no
22. Please indicate any modifications to the vehicle that might help us diagnose better.
23. Upon unscrewing the fuel cap, do you have a large vacuum formed in the tank? yes/no-yes been running with cap loose since i found out
24. Location of PMD/FSD? On the pump/remoted over intake/remoted out of engine bay (please specify placement specifically)-brand new D tech pmd behind bumper on heatsink
24a. If remote mounted, describe wiring harness (homemade or purchased from a vendor?)-came with kit
24b. Indicate the location and condition of the FSD/IP grounding wire. -stock location good condition
25. Are ALL glow plugs in proper working order as per this thread?-yes
 

·
Registered
Joined
·
31 Posts
stumbling

i suggest you check for vacuum leaks or air getting into your fuel system. just my thoughts
 

·
Premium Member
Joined
·
9,258 Posts
theres a boost diagnostic checklist in my signature, go through the boost help, and reply back...P0238 is a boost related code
 

·
Registered
1995 GMC Suburban
Joined
·
18,078 Posts
Check the vac system leak. Most of the time it is the Turbo Wastegate Solenoid unless the vac pump is out.
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #5 ·
Ok found out my wastegate is not opening. It works intermittently. Some days it is fine others it sticks. Any way to repair or should I just but a turbo master? What would cause it to not open?Looked at the vacumn lines and they appear to be fine.
 

·
Registered
Joined
·
3,364 Posts
your wastegate solenoid, or the plug to it might be shot.
Check the wires, wiggle them a bit and see if the actuator works or not.

Most of the time, the actuator by itself is pretty solid.
Common failures are vacuum pump itself, vacuum lines, very often, the wastegate solenoid or it's plug/connector.
 

·
Premium Member
Joined
·
9,258 Posts
sounds like solenoid/plug to me...check the vacuum lines too
 

·
Registered
1995 GMC Suburban
Joined
·
18,078 Posts
Never check a vacuum line just by looking at it. You have to plug a gauge with it. Most of the lines are hidden and snaking around the engine and it is hard to see if it is leaking.
 

·
Registered
Joined
·
574 Posts
Buy a cheapo hand vac pump for testing this system. I think I got one for $10 at princess. Mine had similar issue so I vac tested the system one part at a time. If each section holds vacuum then it is good.

I had a small piece of RTV stuck in the inlet port of my boost solenoid, thanks PO.
 
1 - 9 of 9 Posts
Top