Diesel Place banner
1 - 20 of 35 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter · #1 ·
hi guys, it started like every other limp story: edge on 5/5, running the 1/4 and suddenly.....nothing over 2000 rpm. no big deal, i had heard about this. then it got more and more frequent and on lower levels, first 4 then 3. not long after that it started limping on stock tune and now with the edge completely unhooked. it does this every time i drive my truck, with out fail. i tryed the shim mod (.39)with no avail. it seemed to be worse. some one mentioned the sending unit in the tank, changed it out, nothing. its at the dealership now, where i work. the tech said it shows to go to about 12500 psi when this happens. he says he doesn't know what the deal is and he's taking a long weekend so i am taking my truck home. any suggestions on what to do next. should i remove the shim, or maybe i did something wrong while doing the mod. i went just as easily as everyone here said it would. any help would be greatly appreciated. BTW, the truck has 60,000 miles, i have changed the fuel filter 3 times in the last month, hoping that is what was wrong, and the check engine light has never came on. please help:(
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #2 ·
i know my this is my first post with a big long question, but i've ran out of options. no one seems to know why my truck won't go.
 

·
Premium Member
Joined
·
20,556 Posts
what codes is it throwing? I would assume a 1093...
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #4 ·
the tech is at lunch right now, i'll ask when he gets back.
 

·
Registered
Joined
·
1,371 Posts
If it is fuel related as it sounds, it isn't really "limp". Limping implies a tranny problem usually due to excessive horsepower.

Good Luck getting to the bottom of this!
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #6 ·
well, the best i understand from the information on the forum, it's an engine limp mode i.e. will not rev over 2000 rpm. runs fine up until, but nothing after. i may be wrong though
 

·
Vendor
Joined
·
9,677 Posts
Next (and my first) step would be adding lift pump supply...
 

·
Registered
Joined
·
562 Posts
You need a Lift pump, and billet pick up, and Shim mod wouldn't hurt also.....

I just finished dual lift pump and billet pick up install today very slick only took 3 hrs to get everything right and set up!!!!:ro) :ro)
 

·
Registered
Joined
·
1,460 Posts
no leace the sim mod in.
i think dino one ment that shim mow wouldn't hurt not would hurt
 

·
Registered
Joined
·
562 Posts
I mean wouldn't sry. If you have already done the shim mod then you need a lift pump while your down there if you have the cash get a billet pick up from a vendor here. :ro) :ro)

should i take the shim out
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #13 ·
does anyone suppose i messed something up with shim mod. the truck won't go over approx. 12500 psi now
 

·
Registered
Joined
·
1,460 Posts
you could have screwed something up take it out and just redo it
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #19 ·
gonna try the redo tomorrow, yes it does it stock. everytime i drive the truck.
 
1 - 20 of 35 Posts
Top