Diesel Place banner

1 - 17 of 17 Posts

·
Whipper Snapper
Joined
·
4,490 Posts
Discussion Starter #1
I finally got a Stealth 215hp tuner on Monday and tried to install it without luck. It went through the programming and counted to "1C" on the "Installing" screen and than says wait 15 seconds and than says "the power has been unleashed" but it hasn't been.


I tried installing just the tune w/o removing the governor and without adjusting for tires. I tried installing different tunes, all with the same results. I finally pulled the three fuses listed in another forum and disconnected the batteries, made sure the SES light was out, and tried all of these things again, w/o luck.


I finally got to talk to Jeremy at Quadzilla yesterday and they were able to send me a new one because the other one was an old version (v1.08). So, I received the new one today and same things happen. I pulled the fuses again and disconnected the batteries, etc. and still nothing with the tuner.


Talked to Jeremy today and he said he put this exact tuner on his '03 yesterday before shipping it to me and it worked fine for him. I have an '02 w/ Onstar (though I don't use it) and I am open to any suggestions while I wait for Quad or Jeremy to call back with other suggestions.......
 

·
Whipper Snapper
Joined
·
4,490 Posts
Discussion Starter #3
No, they can be used on any Duramax. Once they are installed though, you can't use it on another truck until the programming has been removed from the first truck.


Jeremy at Quad said that the programming is not specific to any one model year of the Duramax (the programmers should work on all '01-'04 models I believe).
 

·
Registered
Joined
·
1,685 Posts
What tune are you planning on running?


I hope you don't load the 215 on the stock tranny, unless you are planning on a new one real soon!
 

·
Whipper Snapper
Joined
·
4,490 Posts
Discussion Starter #5
Suncoast is on order... Just waiting for Joe to finish up the new goodies. I talked to him today and he's supposed to be shipping the upgraded "stage V" transmissions in about a week or so... Plus 5 days to get to me and we'll be smokin!


I would just be happy to get the 70hp tune to work as it would be progress!
 

·
Registered
Joined
·
7,187 Posts
sp33d said:
Suncoast is on order... Just waiting for Joe to finish up the new goodies. I talked to him today and he's supposed to be shipping the upgraded "stage V" transmissions in about a week or so... Plus 5 days to get to me and we'll be smokin!


I would just be happy to get the 70hp tune to work as it would be progress!

I am sure that the problem will be corrected..........hang in there, it is definately worth the wait......don't give up.


I had the same problem as well......2002 NO On-Star...it was resolved.





T
NY
 

·
Whipper Snapper
Joined
·
4,490 Posts
Discussion Starter #8
Tony,


Do you know what they did to resolve the problem?


Chad
 

·
Registered
Joined
·
7,187 Posts
sp33d said:
Tony,


Do you know what they did to resolve the problem?


Chad

I spoke with Quad directly..............my first Tuner was version 1.10 and did all the motions but failed to load a tune........it was replaced with another tuner with v1.12 and all was well.......



It may have been that "Tuner" did not like my truck?????............never asked........it was promptly replaced and problem solved.....



T
NY
 

·
Whipper Snapper
Joined
·
4,490 Posts
Discussion Starter #10
Well, that's pretty much what I'm waiting for now. I have been playing all night and nothing...


My first tuner was v1.08. The tuner I have now is v1.12. I don't know, may just be a fussy truck (wouldn't surprise me). I am just waiting for Quad or Jeremy to call me with more suggestions... Thanks for the responses though.


I'm just gonna through the juice back in for now. It was SOOO hard driving home from work tonight with *nothing* ...
 

·
Registered
Joined
·
12,262 Posts
sp33d said:
Well, that's pretty much what I'm waiting for now. I have been playing all night and nothing...


My first tuner was v1.08. The tuner I have now is v1.12. I don't know, may just be a fussy truck (wouldn't surprise me). I am just waiting for Quad or Jeremy to call me with more suggestions... Thanks for the responses though.


I'm just gonna through the juice back in for now. It was SOOO hard driving home from work tonight with *nothing* ...
Come'on know ..... I just drove 100 miles in a stock 02 dually 4x4 with 49k on the clock .... Wasn't half bad,a bit refreshing .... Quiet and smooooth !!!! Kicked back and listened to comedy on XM .... I gotta get it !!!!

Mac
 

·
Registered
Joined
·
2,341 Posts
I had an On-Chicken-Crap problem doing a download. I resolved to disconnecting the big brown plug by my left foot. I could start my truck but the On-Slowly was "gone". I then refreshed my truck and all is well. BTW, I did get a sweep the first time and On-garbage wiped out everything, my XM was toasted as well. It took 12 hours in "contact range" for the On-Stabb-UR-Walet to reboot everything. It's quite frustrating the first time you loose everything. --- Pulling the plug did the trick for me.






Burner-------->
 

·
Registered
Joined
·
2,570 Posts
I've tried 3 tuners ... a 1.04, 1.08 and a 1.10 all with problems so I gave up and back to my Juice. Each truck is different and mine apparently is really different, step child, black sheep, etc.
 

·
Whipper Snapper
Joined
·
4,490 Posts
Discussion Starter #14
I finally got one that works! They say "third time's a charm" and it is.


This thing is unbelievable. The transmission has absolutely no chance of keeping up with me now! First run of 0-100+ (since I don't have a speed limit now!) zinged the tranny at 102



Guess I'll have to wait for Suncoast to get here before anymore of those runs. I was really suprised the tranny didn't kick out sooner than that, though.


The power doesn't quite seem to be at the bottom like the Juice, but it quickly makes up for it once the turbo spins up (ask a poor couple standing on the side of the road that I didn't see until it was too late). I've got a little driving to do for the transmission to learn as it's shifting pretty awkward right now (even at a "mild" acceleration speed), but I am impressed. Just for the hell of it, I put the Juice 125hp on to, and that just didn't work too well. The truck was accelerating so fast that everytime it would shift, I would fall forward. Needless to say, I took the Juice off after a few minutes. I'm gonna drive around with the Stealth for a few days and see how it does.


I have to give John Kennedy and Quad Boenker (and Jeremy at Quad) a huge thanks! John called several times to make sure Quad was following up and taking care of me. When I ordered this tuner, I had ordered a whole bunch of other stuff from John and I had priced things out and he was only about $50 more on an order of well of $2,500. It was well worth that $50 to deal with someone that shared his knowledge and took care of things. I will be buying from him again in the very near future.


Quad also took good care of me. He overnighted me two seperate tuners to different days to make sure I was taken care of. Heck, he was even willing to overnight a third one to the dyno shop in Denver that is having a dyno day tomorrow, as I will be attending that and he didn't want to me to go without. I'm glad it didn't come to that, but Quad and his staff definitely made sure I was taken care of. I will definitely be doing more business with them in the near future as well.


Thanks to everyone for the help!
 

·
Registered
Joined
·
7,187 Posts
sp33d,


Quad and Jeremy are first rate..................



Talk about a company and persons willing to go the extra mile to make things right.


Awesome product and service !!!!!





T
NY
 

·
Registered
Joined
·
2,570 Posts
GMC-2002-Dmax said:
sp33d,


Quad and Jeremy are first rate..................



Talk about a company and persons willing to go the extra mile to make things right.


Awesome product and service !!!!!





T
NY

I'm glad your experience was a positive one.
 

·
Registered
Joined
·
238 Posts
Guess I will see you tomorrow at the Dyno thing. I have a white 03 dually. Not sure that I am going to make a dyno run.


Jess
 
1 - 17 of 17 Posts
Top