Diesel Place banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Whats up guys,
Picked this truck up a few days ago and have a question for the diesel vets out there. This is my first diesel and have already learned a ton reading the FAQ's. Couldnt seem to find a quick fix for this problem I have found.

During cold start I wait for the glowplugs to finish and the I start it and it runs great idles awesome. Drive to where ever I need to go smooth as a cadillac( a really long, heavy, beat up cadillac). My problem is it seems that if I let the truck sit for maybe 25 minutes or so obviously it does not tell the me glow plugs are on so I start the truck and it starts right up. After 5-10 seconds it starts studdering and then stalls. Will not start back up unless the gas pedal is fully depressed and then it slowly gets going again and then does not have a problem. I found that if I cut it off and then back on theres no ptoblems. Also if I give it gas right before it stalls it will stay running and work fine.
To me this definately seems like the truck is losing fuel pressure while sitting. What do you guys think??

Also just wondering what tells the glow plugs when the engine is cold enough to require there help or vice versa??

Thanks in advance for your help.:help2:
Also if you need more info on the truck im still working on going through the codes to see what I have. All I know is its an automatic, 1 ton 8 lug, non limited slip, equipped with the biggest rear drums I have ever seen in my life.

Elliot
 

·
Registered
Joined
·
7,134 Posts
I think you need to check the lift pump and OPS as per the sticky for your stalling problem. If you do a search you'll find plenty of info on the CTS and what it does. And thank you for having your sig filled out as per the welcome note. It really helps us to help you, and keeps the mods happy:cool:.
 

·
Registered
Joined
·
4,805 Posts
fyi- even when the engine is warm, the glow plugs should cycle before start up. They won't stay on as long as when the engine is cold.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
thanks guys, I will check the ops tommorow along with the lift pump. The glow plugs do not cycle after it is warm. If they do the light on the dash does not come on.
 

·
Registered
Joined
·
4,805 Posts
this points towards an electrical problem. Clean your battery connections and check all grounds.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Replaced the oil pressure switch and now I can start and stop it when ever I want. Runs like a champ! Thanks for the help guys.

Elliot
 
1 - 6 of 6 Posts
Top