Diesel Place banner

1 - 14 of 14 Posts

·
Registered
Joined
·
861 Posts
Discussion Starter #1
Sometimes when driving my dmax when i hit the gas from a stop it just about dies. the rpm's drop and it doesn't do anything for about or 3 seconds. then it just takes off. it only happens like once a month but it has me wondering what it is? it has never died but it feels like it is about to. so what could it be?
 

·
Registered
Joined
·
91 Posts
Mine has done this many times, I believe its something to do with the drive by wire system, it apparently gets its little brain messed up. Step on the throttle pedal and nothing, back off, then step on it again and it takes off. Complained to stealer but they could not duplicate. It happens about once a month, though its only a minor irritation.


Engineer Bill
 

·
Registered
Joined
·
3,410 Posts
If you are having it do this only from a rolling stop. It sounds like it is the transmission getting lost for a second. Once in a while the truck forgets to down shift until you start to go. It then is lost and trys to shift at the wrong time.
 

·
Registered
Joined
·
7,187 Posts
If you have version 4.30 or 4.35 that may be it.


Look on the bottom of the Juice for the sticker.


It should list the version number.





T
NY
 

·
Registered
Joined
·
861 Posts
Discussion Starter #7
my juice is version 3.2 c
 

·
Registered
Joined
·
7,187 Posts
You have an old version......no confirm of settings thru revs.


I would recommend upgrading the version to the 4.61. That is the last non-attitude version EDGE made befor the newer Attitude boxes were released.





T
NY
 

·
Registered
Joined
·
861 Posts
Discussion Starter #9
so it is the juice causeing the problems?
 

·
Registered
Joined
·
9,300 Posts
I have this problem too. I step on the gas and it hesitates a 1/2 second. It does this maybe 2 time per month sometimes a little more.
 

·
Registered
Joined
·
12,262 Posts
tmg115 said:
my juice is version 3.2 c

There was a problem with the Edge Juice early on that was fixed with a revision ... You would benifit from a upgrade nontheless...


Is the Box causing the problem ?? Easy enought to tell by removing the Juice and see if problem goes away ...


Mac
 

·
Registered
Joined
·
120 Posts
The other day in my 'O2 I was pulling a pretty muddy road with a load of hay at @40mph and mine stumbled and started blowing smoke out the tailpipe, I let off the fuel and let it coast and set for maybe 10 seconds and then it went on. This is the first time thats ever happened and I'm running a regular Juice version 4.61 and a K&N.


I probably should have had it down in tow/haul pulling that road but didn't. Does anyone remember something about cleaning the MAF sensor or something . . . and how do you do that? Have any opinions on the cause of this?
 

·
Registered
Joined
·
557 Posts
Was it raining, such that you had your wipers on?
 

·
Registered
Joined
·
120 Posts
No, that day it wasn't raining (I don't think). Now when its raining it won't just pull down and blow smoke like that BUT the motor will sometimes get a lot louder than normal. When it has done that I've turned the wipers off and waited then back on after a while . . . no difference.
 
1 - 14 of 14 Posts
Top