Diesel Place banner

1 - 5 of 5 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter #1
Changed my spin on filter today, truck has been sitting two days in garage, lost very little fluid when I took the filter off and filter was full. I filled the new filter to the top and added what I thought that I lost when I first unscrewed it. Total fluid used after filling up the filter and what was put back in was a total of 1/4 of a quart. I can't get the trans. temp up high enough to check it because it is 15 deg. here. In the book it says temp needs to be 160-200 when checking hot. I got it up to about 125 and it was reading between the cold and the hot. what do you guys think?
 

·
Registered
Joined
·
4,796 Posts
The amount of fluid that you added is just fine.
 

·
Registered
Joined
·
1,437 Posts
You are good to go.
 

·
Registered
Joined
·
2,331 Posts
jixxer;1573237; said:
Changed my spin on filter today, truck has been sitting two days in garage, lost very little fluid when I took the filter off and filter was full. I filled the new filter to the top and added what I thought that I lost when I first unscrewed it. Total fluid used after filling up the filter and what was put back in was a total of 1/4 of a quart. I can't get the trans. temp up high enough to check it because it is 15 deg. here. In the book it says temp needs to be 160-200 when checking hot. I got it up to about 125 and it was reading between the cold and the hot. what do you guys think?
Right in the middle is where a lot of members think it is the best place to have the fluid level at...
 
1 - 5 of 5 Posts
Top