Diesel Place banner
1 - 6 of 6 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
I have an '05 with 50K on the motor and this last saturday , the speedometer while operating at 65-70 mph, started to creep up until it ended past the 120mph mark. And stayed there. I finally got her back to normal, but what may have causes this strange phenom.
 

·
Registered
Joined
·
103 Posts
The stepper motor in the instrument cluster assembly tends to go in these things. Mine is currently being replaced. Another indication is if the speedo gets stuck on a speed while stopped rather than "0". Some dealers try to reprogram the speedo. Best bet, if covered under your warranty, get a new instrument cluster. It's a known problem!!!
 

·
Registered
Joined
·
41 Posts
See my post below for the fix.
 

·
Registered
Joined
·
816 Posts
Skidoo xtreme;1542859; said:
See my post below for the fix.
Try to post again please.
 

·
Registered
Joined
·
41 Posts
What I ment to say, is look just below this topic under interior and I have posted a repair for the speedometer problem along with parts and equipment to do the job.

Good luck with the repair. Parts cost $14.50 per gauge.

Matt

Here is the link

http://dieselplace.com/forum/showthread.php?t=129864
 

·
Registered
Joined
·
101 Posts
Same problem here...

I have an '05 that has a speedo that "hangs" or says i'm going faster than I am.... GM acts like they know nothing. Filed my complaint with the NHTSA.com web site...we should all do the same!

FYI...some of the GM technical data says its a bad ground at the cab mount just under the front of the driver side front door. If you have tube steps follow the front bracket and you will find the ground. figured I would try that before I mess with the cluster.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top