Diesel Place banner

1 - 10 of 10 Posts

·
Registered
Joined
·
225 Posts
Discussion Starter #1
Hi,
My '02 DMax now has a little over 63k miles. Right from day one, the truck would have an inconsistent slight idle "pulse". I wouldn't call it a surge, but the idle wouldn't always be smooth.
I've complained to the dealer a couple times. They said they reset the computer once, or updated the software, and that cleaned up the idle for a while, but the rough "pulse" would come back.
I've since installed the Banks Stinger and exhaust brake kits. That pulse is still there. It's more frequent when I'm waiting at a red light. Simply popping it from drive to neutral will clear up the idle. Other times it will have that idle issue even in park.
Unhooking the batteries to install the high idle and overdrive lock-outs didn't clear things up either.
So...it's really inconsistent, so the dealer doesn't want to look for it, scan for codes, or anything. Says "it's the Banks kit, and BTW no more warrantee" until I remind them the idle issue was there before that kit was installed and they tried to fix it then - unsuccessfully, then they say "it's normal". Just like the sound that I'm convinced sounds like an exhaust leak but they say it's just likely an "air echo" through the intake system...but given that they don't know what TransSynd was, I'm not exactly putting a lot of faith in their non-diagnosis either.
DmaxalliTech, without any more info, can you state whether my truck is acting normal or not, of if this should be further pursued? With injector conversations and the costs of replacement pumps, I'm naturally paranoid...
Thanks,
--Rob
 

·
Registered
Joined
·
11,646 Posts
I would be curious as to the pattern on the tech 2 of actual vs desired fuel rail pressure


could be a sticking regulator....
 

·
Registered
Joined
·
994 Posts
If I remember correctly, the 2001 and very early 2002 had this problem. They changed the ECM software in very early 2002. If that did not solve the problem, I thought they were changing the fuel pressure regulator?
 

·
Banned
Joined
·
6,539 Posts
Mine does it too but has recently gotten much worse. The rule back when the 01's came out was if it only did it when it was cold, a reflash was supposed to help... didn't for me.

Then they said if it also does it when the engine is hot, the rail pressure control valve is bad. They supposedly redesigned the valve from reg steel to stainless. It's an integral part of the high pressure pump so they replace the high pressure pump. My truck didn't do it when hot until recently. Even before the Juice.Edited by: hoot
 

·
Registered
Joined
·
403 Posts
Hoot,


Mine just started doing this at 56,000 miles..... I have never run any power adders....


The funny thing is, sometimes it's there, sometimes its not.... but it is definately more noticable when the truck is warm.


One other thing I've noticed, at idle when warm, the oil pressure guage fluctuates/surges with the idle surge. Anyone experience this?


Anyway, this is definately something that I'll have looked at next time I'm at the stealer...... Edited by: Blinky
 

·
Registered
Joined
·
336 Posts
My truck has done this since new. It hasn't caused any problems so I figure I'll live with it. The gauges remain normal when it experiences this surge. It has done it when cold and warm outside.
 

·
Registered
Joined
·
95 Posts
Mine did it. Fuel pump was replaced under warrantee, and it idles perfect ever since. You do not have to live with this annoyance. Now they just replace the fuel pressure regulator, not the whole pump assy.
 

·
Registered
Joined
·
6 Posts
Sounds like a bad fuel rail pressure reg mounted on the top of the injection pump. I have replaced 10-20 on the dmax. hope this helps
 

·
Registered
Joined
·
994 Posts
Mahotas -


Off the topic a little bit but how many injectors have you replaced (out of curiousity)?
 
1 - 10 of 10 Posts
Top