Diesel Place banner

1 - 20 of 30 Posts

·
Registered
Joined
·
617 Posts
Discussion Starter #1
Bought a Banks Six Gun with the speed loader in early March to get ready to tow my 15K lb 5er from Las Vegas to Mississippi. Installed no problem, worked fine around town. I put this thing on #2 to help me pull some of the hills on I-40 in 5th gear. When I made it over about 4,000 feet in elevation my truck would cough black smoke and buck. Felt like I was riding bareback. Turned the tuner to #1 (stock) and called Banks tech support from the road. About an hour later Banks was stumped and told me I had to send it back for a replacement. No problem, what's the address? Then I get, "you mean you didn't buy it directly from us, well I can't help you. You have to call the guy who sold it to you so he can contact us and get a RA number." Called the place where I bought it and he couldn't believe it, said he was a Banks Master Dealer and never had to play middleman. Banks told him I had a problem with my accelerator position sensor (foot petal) that’s why I wasn't going as fast as I wanted to. Uhhh fast is not the problem, hopping up and down like a toad in a sack is. Tuner is on it's way to them now as I didn't have time to take it out until this weekend with all the traveling I've been doing. We'll see how Banks handles it. My warning to anyone who wants the Banks Six Gun, if you don't buy it from them they WILL NOT HELP YOU if you have a problem. You have to do everything third party. The factory sealed box the Six Gun/Speed loader came in had instructions for a Dodge and they wouldn't even confirm if the part numbers were for a Duramax or even give me an electronic copy of the install instructions because I didn't buy it from them. That's pure crap. The Customer Service Rep said that's what I get for not buying directly from the factory, and that it's not Banks fault that BANKS packaged the box with the incorrect install manual. What an idiot. Edited by: neverenuf
 

·
Registered
Joined
·
1,958 Posts
Thank you!!! Now I know when they come out with a unit for the LLY I will NOT buy one of theirs!!!
 

·
Vendor
Joined
·
9,676 Posts
Are there any blinking code lights?





I've found switch initialization issues when installing these. Once the switch codes are cleared all is well. It's not a barnstorming box by any means, but it does add power...
 

·
Registered
Joined
·
958 Posts
Boy if I was a Banks vendor I'd be very pissed to hear this. Sounds like they're trying to leave the vendors high and dry and make the extra profit themselves.
 

·
Vendor
Joined
·
9,676 Posts
This is the independence of the Banks sales reps speaking. Truth is, the selling dealer is generally the one to cover things like this, but in a situation where you are on the road, an exception could surely be made.





On edit to my original post, something sounds wrong with the unit. My suggestion would be to remove the speed loader and disconnect the probe. Could be Defuel bucking from a faulty EGT probe or signal...
 

·
Registered
Joined
·
292 Posts
I had exactly the same problem with the Banks people myself. I found them to be very arrogant, pushy (instead of helping me, he kept trying to get me to buy all sorts of other equipment like the big head wastegate, exhaust and new intercooler) and when they learned that I got it from someone else, he suddenly had no more time for me. End result? I sold it on EBay and got the Edge who has superior customer service IMHO.
Edited by: hasselbach
 

·
Registered
Joined
·
1,715 Posts
<font size="6">POS TUNER AND CUSTOMER SERVICE.......where you at peter</font>
 

·
Registered
Joined
·
10,516 Posts

·
Registered
Joined
·
310 Posts
Jeez, I hate it when he minces words like that. Just spit it out, Dave.






Hey, I clicked on the email link, didn't work.
 

·
Registered
Joined
·
1,469 Posts
neverenuf,


Repeating what Kennedy asked, did you look at the Six-Gun module before pulling it out of the truck? There had to have been a code blinking. This is the first time I've heard of an actual problem with the Gun. (Not installing the TCM or EGT probe for the auto or speedloader don't count-it explains everything in the manual).


As far as the Banks customer service goes, I don't agree that's the way you should be treating your buyers, whether you bought direct through Banks or not. I was one of the very first to purchase this product, and I've had no problems thus far. I did buy directly from Banks because I wanted it RIGHT NOW. Sorry to hear of your ordeal.


Keep us posted as to what was actually wrong with your module.
 

·
Registered
Joined
·
292 Posts
With regards to selling us pencils,


You can Bank(s) on it that we'd expect decent customer service after going to the Bank(s) and withdrawing $650 bucks for something that is not working right!
 

·
Registered
Joined
·
16 Posts
hasselbach said:
I had exactly the same problem with the Banks people myself. I found them to be very arrogant, pushy (instead of helping me, he kept trying to get me to buy all sorts of other equipment like the big head wastegate, exhaust and new intercooler) and when they learned that I got it from someone else, he suddenly had no more time for me. End result? I sold it on EBay and got the Edge who has superior customer service IMHO.

That's the same problem I had with banks. I too sold it on ebay and got the edge. I'm happy now.
 

·
Registered
Joined
·
617 Posts
Discussion Starter #15
I have a PM going with PeterT right now and he seems very eager to do the right thing now. He also mentioned that Banks can handle any warranty issues directly with the customer. Maybe a policy change? Banks told me, through the company I bought it from, not to send the speed loader back just the module. When not hooked up to the trailer the unit was fine until this weekend when I set Po840-Transmission fluid pressure sensor/switch "A" circuit, and P0843-Transmission Fluid Pressure sensor/switch "A" circuit High. Could be or could not be caused by the Six Gun, but the MIL light did clear when I removed the box. I had a solid green light on the box all the time, except when initial startup the light would flash indicating the speed loader was installed.


Maybe this could be good for all of us who owns Banks products and they are as willing to help those of us who bought their products elswhere as they are to those that bought them "in house".





Kennedy


When I was on the phone with the tech guy he was under the impression that I bought the unit from them. He told me when I stopped to call them and they would send me a unit FedEx where ever I was and I could send the one back when I got the replacement. This was obviously before I told him I bought it elsewhere. The tech guys were real interested in the problem as they have not heard of it before, and they were good to talk with. It's just the policy at the time that sucked. Hope it changes.


Before we go off the edge here guys lets see how Banks will handle this one.
 

·
Vendor
Joined
·
9,676 Posts
Be sure to keep us posted as to what the problem is/was.





PS. IMHO, the rhythm for the codes is kinda slow. The green ilight will illuminate, and the code will wait a few seconds, then blink, then the green light will return IIRC.
 

·
Registered
Joined
·
520 Posts
"Before we go off the edge here guys lets see how Banks will handle this one"


No pun intended?





Good one though!
 

·
Registered
Joined
·
7,187 Posts
All I know is that I bought my first Edge 90hp Juice from an Edge Dealer and it has been reflashed or exchanged by Edge twice for updates without any questions asked.


Even though I did not buy directly from the factory.


That's what customer service should be............


T
NY
 

·
Registered
Joined
·
228 Posts
GMC-2002-Dmax said:
All I know is that I bought my first Edge 90hp Juice from an Edge Dealer and it has been reflashed or exchanged by Edge twice for updates without any questions asked.


Even though I did not buy directly from the factory.


That's what customer service should be............


T
NY

Tony, how do you know when to send your juice in for a refill (reflash/update)? Does it take long? And if you're up to answering this one...Once you've reflashed are all aspects of this product improved or just certain parts? Thanks for any info.
 

·
Registered
Joined
·
617 Posts
Discussion Starter #20
Banks sent me a new Six Gun, along with a complete new wiring harness. I talked with PeterT multiple times on the telephone and also had a conference call with Peter and one of the head engineers for Banks to explain how the truck was behaving when I was having the problem. There were no codes stored on the SixGun and it tested OK. Still don’t know what the problem was, but they are working on it. They sent me a new unit UPS Air as soon as they received the old one, pretty impressed with that. Peter again assured me they can handle all warranty claims directly without going through the selling dealer, don’t know why I was given the run-around. Get this, the SixGun, OttoMind and BigHead Wastegate Actuator all received CARB E.O. numbers. So now I’m 50 state emissions legal. They sent a sticker with the numbers on it along with the products covered, the number is D-161-74. Guess that part was true. I’ll install the tuner this week and see how it acts. Once PeterT got involved I was very pleased with the customer support. If anyone has problems with a Banks product, I wouldn’t waste time with just calling and asking for help, call him first.
 
1 - 20 of 30 Posts
Top