Diesel Place banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1 (Edited)
I resently got a 70 hp reprogram on my 04 lly and now have a delay in shifting gears. This is what happens.. On a full throttle acceleration the tack goes to 3200 rpm and stays there for a second or two then shifts down and goes. It happens at 80km/h and 122km/h, both times goes right to 3200 rpm. It will not accerate past this speed until it down shifts. If I let off the juice just a bit it will shift down to the next gear. Am I slipping my Allison? Or is this just a defuel?:(
 

·
Registered
Joined
·
90 Posts
Sounds like your tranny is trying to "re-learn" the new hp and torque curve. I'm sure sombody else will chime in.
 

·
Registered
Joined
·
199 Posts
agreed, give it a little while. it takes a mixture of city/highway, heavy/light driving. the allison is learning transmission it takes a few days to correct itself, but don't worry you'll be fine.
 

·
Registered
Joined
·
1,293 Posts
i have heard that it takes about 30 miles to relearn after a program install.
 

·
Registered
Joined
·
577 Posts
If I understand correctly, the time required for the transmission to adapt to a different power level is dependant on the number of transmission upshift and downshift cycles and the number of times the key is turned on and off.

:)
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
At a 70 hp bump is there any risk to the tranny? The reprogram I got put in was from Wester's. But it was 4-5 WEEKS ago, so how can it still be learning?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
After reading here and trial and error. I think I have a stuck egr valve. Night and Day difference. I managed to unplug the egr when I had some get up and go. Shifting nice and lots of torque now. Could it be that simple???:rolleyes: I am going to leave my egr unplugged awhile and see what happens.
 
1 - 7 of 7 Posts
Top