Diesel Place banner

1 - 18 of 18 Posts

·
Registered
Joined
·
955 Posts
Discussion Starter #1
I got in my truck yesterday after work and shortly after I started my truck up I got a double ding ding and saw the messages for "SERVICE STABILTRACK, SERVICE TRACTION CONTROL, and SERVICE TRAILER BRAKE SYSTEM". And now I've got my ABS light on. What the hell happened?

I can't find anything in the owners manual.
Anybody out there have these messages come up on their truck?
If so, what did it take to get it fixed?
 

·
Registered
Joined
·
342 Posts
Sounds like it's time to bring it in....obviously something bad happened. Best of luck.
 

·
Registered
Joined
·
4,164 Posts
I seem to remember reading something about that on here when all three warnings popped up, but I can't find it....

I would just bring it in to the dealer.
 

·
Registered
Joined
·
955 Posts
Discussion Starter #4
I got in my truck and did some errand chasing and no messages today....weird. :confused:
 

·
Registered
Joined
·
2,851 Posts
Wheel speed sensor failing, out of adjustment or wiring issue...
 

·
Registered
Joined
·
4,164 Posts
Wheel speed sensor failing, out of adjustment or wiring issue...
x2.....When I did a general search for those 3 lights, that's what came up.
 

·
Registered
Joined
·
955 Posts
Discussion Starter #7 (Edited)
It's going in this week for an oil change, engine compartment rattle at about 2800 rpm, and an amp that pops and cuts out from time to time. I'll have them check the speed sensor too.

Thanks for the head's up.
 

·
Registered
Joined
·
276 Posts
Most likely a wheel sensor is dirty or a piece of crud got on it. This can happen after running in inclement weather and when the roads are treated.. I have pressure washed behind my wheels and rotors at a car wash when I have experienced this and solved the problem. It should be a simple fix that your dealer can solve.
 

·
Registered
Joined
·
2,313 Posts
You will always get a service trailer brake if you have an ABS failure. Since you have, ABS/TCS/ESC lights, it is either a wheel speed sensor or a power/ground type fault.
 

·
Registered
Joined
·
955 Posts
Discussion Starter #10
Well, the truck is still at the dealer - they originally said that it was a rear wheel speed sensor, but later in the day I called to see if my truck was ready, they told me that they called GM and now the problem is with the ECM.

I'll find out later today if they fixed it.
 

·
Registered
Joined
·
955 Posts
Discussion Starter #11
Got the truck back last week, they told me that GM told them to swap out the relays for the rear window defogger and traction control. That worked until this afternoon, now it's back at the shop.

They did fix the vibration/rattle under the hood and it turned out to be an exhaust clamp - there's a TSB issued for that item and it took them 2 visits to find it.
 

·
Registered
Joined
·
955 Posts
Discussion Starter #12
You were right Cowboywildbill - it was a rear wheel speed sensor.

Winner, winner, chicken dinner!
 

·
Registered
Joined
·
2,851 Posts
you're welcome..:rolleyes:
 

·
Registered
Joined
·
955 Posts
Discussion Starter #14
you're welcome..:rolleyes:
Man, I completely missed your post - I guess I'll have to pony up another bucket of chicken from KFC. :D
 

·
Registered
Joined
·
133 Posts
I am having the same issue. 425 bux to diagnose and change a sensor is retarded. They dont have the part should I just try to clean it and see what happens?
 

·
Registered
Joined
·
126 Posts
abs

had the same thing on my 011, was a bad wheel sensor, I was towing my 5th wheel at the time, found out right quick that there were no trailer brakes as well. Locked them out, did not make me feel warm and fuzzy losing trailer brakes due to a bad wheel sensor pulling a 14K trailler. GM said it was programmed to do that. DUMB!!
 

·
Super Moderator Rather Be Fishin'
Joined
·
2,904 Posts
Thread moved to Electrical...

Glad you got it solved. :)
 

·
Registered
Joined
·
2 Posts
I have a 2011 Chevy Silverado with 56K miles on it. She gets driven to work and back, nothing off road, no out of town trips. About a month ago I started having problems. I keep having the ABS, STABILITRAK, TRACTION CONTROL, TRAILER BRAKE SYSTEM FAILURE ERRORS COME UP. And to add to the list sometimes the truck will RED LINE to six thousand RPMS and then the truck almost shuts off! The dorr locks will start clicking and the light go on and off.
I know my truck isn't cursed, what the hell is wrong with it!? No one can figure it out!
 
1 - 18 of 18 Posts
Top