Diesel Place banner

1 - 5 of 5 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
My Service Air Bag warning light has recently turned on...

I usually keep my passenger air bag turned OFF...this is when the service airbag displays

Just for the fun of it I turned the passenger air bag ON...the service air bag no longer displays...huh ?

anyone here ever have this happen to them ? If so, what is the solution ?


passenger OFF
IMG_20210403_133026110.jpg IMG_20210403_133040727.jpg


passenger ON

IMG_20210403_133113878.jpg IMG_20210403_133108623.jpg
 

·
Premium Member
2007 Klassic CCSB 2500HD. Six-gun w/speedloader, iDash, and EFILive.
Joined
·
896 Posts
Have you pulled the codes associated with the problem?
 

·
Premium Member
2007 Klassic CCSB 2500HD. Six-gun w/speedloader, iDash, and EFILive.
Joined
·
896 Posts
Have you pulled the codes associated with the problem?


And out of curiosity, were you in the vehicle with it running and the seatbelt off when you took those pictures? The truck thinks you're in it with the seat belt off and the engine running. Part of the airbag system relies on seat belt circuitry.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
Have you pulled the codes associated with the problem?
my scanner doesnt show any codes....only the 0380 code for the damn glow plugs
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #5 ·


And out of curiosity, were you in the vehicle with it running and the seatbelt off when you took those pictures? The truck thinks you're in it with the seat belt off and the engine running. Part of the airbag system relies on seat belt circuitry.
the seat belt was off when I took those pics...BUT...it does the same thing when the seat belt is on...no difference

its seems weird that it appears fine when I turn the passenger airbag on ????
 
1 - 5 of 5 Posts
Top