Diesel Place banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,079 Posts
Discussion Starter #1
Started my truck today and DIC said 'service 4wd'

I'm at about 45k, is this something that randomly pops up around this mileage?

Just curious what service they'd perform on my 4wd at 45k?

Thanks.
 

·
Premium Member
Joined
·
20,561 Posts
it means soemthing is "broken" in the transfer case module, 4x4 switch, front axle, encoder motor....

there should be codes stored that can better help you. Try to get those read..

---Ben
 

·
Registered
Joined
·
1,079 Posts
Discussion Starter #3
Thanks Ben. Seems odd since I haven't had it in 4wd for a while?
I need a tech II for scanning or can the predator I just bought do that? (it's not here yet)
 

·
Bac To The Future
Joined
·
23,029 Posts
yitsock, did it just come on briefly at startup, or stay on as you drove the truck? Sometimes, the encoder won't "wake up" on time when the truck is started, and it'll throw that light on for a second.
 

·
Registered
Joined
·
626 Posts
Had it happen to me and it was the dash switch for the 4x4. Service is recommended at 50k.
 

·
Registered
Joined
·
1,079 Posts
Discussion Starter #6
Only on startup then it went away... I've started up a few times since then and it hasn't happened. Maybe it's where I put in my fuse tap? I'll go back and see which one I tapped into and see if anyone knows if that will do it?

Thanks guys,
Chris
 

·
Registered
Joined
·
1,079 Posts
Discussion Starter #7
TBC ACCY is the fuse I used to tap into. It's only a 10amp fuse, that shouldn't have anything to do w/ 4wd should it?
 

·
Registered
Joined
·
370 Posts
Had my truck in the dealer last week. They flashed the truck to stop false 4X4 service light. I have never seen the false warning the re-flash corrects. Good luck.
 

·
Registered
Joined
·
1,079 Posts
Discussion Starter #9
I've had quite a few startups and shutdowns since seeing it. Since it hasnt' happened again, guess it's time to ignore it!
:D
 

·
Registered
Joined
·
581 Posts
Mine says that when loading or unloading a tune with Predator and the 3 recommended fuses are pulled under the hood. Goes away after pushing a DIC button.
 

·
Registered
Joined
·
23 Posts
Read my posts in the Drivetrain Forum about Stuck in 4LO. I had this same problem at 108,000. After only a few quick flashes from the DIC "Service 4WD" all hell broke loose on my 2002 Duramax.-:t So far it hasn't been cheap. Try to get yours checked before what happens to me, happens to you.
 

·
Registered
Joined
·
1,079 Posts
Discussion Starter #12
Thanks, I've been keeping an eye on your post.
I should be getting a predator before the weekend. If not, I'll get to an autozone to see what code is being throw.

I'll check through the other thread to see what code you were getting (did the dealer tell you?)
-Chris
 
1 - 12 of 12 Posts
Top