Diesel Place banner

1 - 11 of 11 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
I am going to order a juice with attitude within the next couple of weeks. I have read Hoot's article on mounting of the egt t/c. My question is this are you guys using an existing hole through the firewall to route the attitude cable into the cab or drilling a new hole. I have done a search on the juice and found many ideas on mounting locations for the monitor once inside the cab and the install seems straight forward but none of the existing posts answer my question.


Once again thanks in advance for the help!! This forum is awsome and I am glad you experienced guys don't mind sharing info with the rest of us. Hope I am as happy with the setup as the rest of you seem to be!


Harvey
 

·
Registered
Joined
·
2,341 Posts
Hey Harvey,


I have mounted a few of them and I use the OEM rubber plug behind the fuse box on the floor. You can pull the inside part out and then thread, using a wire, the cable through the rubber seal. The seal is "really" spongy and seems to seal around the cable. So far, for me, that has proved to be the best/most easy way to get into the firewall. Once I've made the passage, I'll run the wire up and behind the dash to the driver's side A-pillar. It's real easy to remove the side pannel by the fuse box and weave the wire in. The pyro install is "exactly" where Hoot has his. I run the pyo wire along the firewall, attatching it to the metal screws. For me, this keeps the wire out of the way and give the appearance of a factory install.


......... others may do it differently, but that's the way I like to do it.





Burner ------------>
 

·
Registered
Joined
·
28 Posts
I was able to install mine without the extra lead. Got some if you need them, but I haven't had to use for 03's at least. Also used the ATS mount in the upper center console and it looks great. Edited by: harleyman
 

·
Registered
Joined
·
119 Posts
I am thinking of installing my atitude down by where my brake controller is, just under the little storage pocket down by the drives right leg. Has anyone else installed it down there. I like the stealth look.


In my Dodge i ran the gauges lower to hide them from prying eyes so others would think a stock truck kicked their butt.


Pros: Cons: anyone tried it?





Thanks, Don Miller


2004 2500HD D-Max (1350 miles), 4" exhaust already
 

·
Registered
Joined
·
211 Posts
harleyman said:
I was able to install mine without the extra lead. Got some if you need them, but I haven't had to use for 03's at least. Also used the ATS mount in the upper center console and it looks great.

Harley man is correct. The controller can be mounted in the O/H console without the extension. We installed one the other day in an 01. I'm not sure where the cable went through the front because the alarm installer had it ran and buttoned back up by the time I finished drilling and tapping the exhaust manifold. There was at least 4-6 inches to spare.
 

·
Registered
Joined
·
331 Posts
Turbo,


I too was thinking of installing the Attitude in the lil cubby hole in the console. Has anyone tried it? It looks like it will fit, even with the ATS mount kit.


Russ
 

·
Registered
Joined
·
249 Posts
I'm thinking of putting mine in the corner of the dash and console. No one could see it, and when it goes to the shop it can be folded under neath. It could be screwed to the metal dash braces.
 

·
Registered
Joined
·
112 Posts
I decided to order the O/H console faceplate from ATS. I just couldn't figure out any other place to put it. The problem now is getting the damn wire through the firewall. I have taken some advice from Burner, and Trippin but I am still struggling with it. I can see or feel the the rubber grommet inside the cab, but not both at the same time. I'm really timid about damaging the wires. I have had problems with GM wiring in the past, without my destructive hands working on them. I will get it done eventually. --SS
 

·
Registered
Joined
·
124 Posts
I "modified" the cheap-as$ arm that came with my Edge/Attitude setup and mounted it in the cubby that the touch-button 4 wheel drive is located (if equipped). I'll beg for foregiveness on my picture quality now.



 

·
Registered
Joined
·
6,504 Posts
FWIW, I upgraded my Juice to v4.73 with Attitude and had some "issues" on Sunday just before hitting the road on Tuesday for Florida. I made up a steel clip-on plate to mount mine on the instrument trim right next to the A-pillar gauges. I routed the cable down alongside the A-pillar and underdash and through the big firewall grommet. The Attitude would alarm and show bogus numbers and the engine would not start!
I disconnected and pulled the wire and all was okay without the Attitude. I contacted Kennedy and Aaron and Aaron told me to check the wiring inside the Attitude where it joined the board. It looked fine, so I went out at lunch on Tuesday and ran the cable around the windshield and over the fender and hooked it up with open hood. It worked fine. I rerouted the cable under dash and it would not work again! It appears that there is an interference problem somewhere under dash, perhaps in my Isspro pyro amp that is mounted right near the firewall grommet. To make a long story short, I ran the cable through the door weatherstrip and inside the fender (which is the Edge "suggested" routing) and it's been running fine for the entire Florida trip.





Edited by: Idle_Chatter
 
1 - 11 of 11 Posts
Top