Diesel Place banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
This is my first time using a forum and really looking for some help. Have a 2004.5 lly and have done the following since I bought it- New headgaskets and studs, all new fuel lines and hoses while apart for headgakets, got the injectors flow checked and all checked out perfect, deleted and tuned, 5" exhaust with 3inch down pipe. Truck has a cold air intake fass 150 and sump. Truck ran great when I got it back then 3 months later my dsp5 switch seemed to quit working like i lost my tunes and if i move the switch to any other tune than one it runs like a crap and somehow tune one feels like the hot tune which used to be my tune 5. Now my balance rates jump around and has a rough idle, white smoke at takeoff doesnt really haze any at idle, and feels like it loses power when it shifts and kinda falls on its face. Any help would greatly be appreciated and cant afford to go to a shop so gonna have to try and figure this out like i have been the past month as its gotten alittle worse.
 

·
Administrator
Joined
·
16,738 Posts
Welcome to DieselPlace
Checked for any codes?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Welcome to DieselPlace
Checked for any codes?
yes no codes showing expect for egr codes but they dont cause the check engine light to come on.
 

·
Administrator
Joined
·
16,738 Posts
yes no codes showing expect for egr codes but they dont cause the check engine light to come on.
Inspect your engine harness and all connectors for any rubbed through wire insulation, corrosion, broken wire, etc.
Start and idle the engine and grab the harness and give it a few shakes to see if anything changes
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
also i forgot to add that when my truck was in a shop they messed up and didnt hook my dsp5 switch up so wires might have touched or hit a piece of metal under the dash so could that of messed up the computer? or messed my tunes up making it run bad?
 

·
Administrator
Joined
·
16,738 Posts
also i forgot to add that when my truck was in a shop they messed up and didnt hook my dsp5 switch up so wires might have touched or hit a piece of metal under the dash so could that of messed up the computer? or messed my tunes up making it run bad?
You should have a code(s) but it's a possibility.
You could hunt for a wrecking yard ECM similar to your truck and switch it out with yours and see if it changes things.
 
1 - 6 of 6 Posts
Top