Diesel Place banner

21 - 40 of 51 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #21
No. Difference with mag unplugged
 

·
Registered
Joined
·
34 Posts
Discussion Starter #22
i can't find a s motorcode on a 2000 chevy truck by domestic snap on catdrige

some data:
RPM 1298
MAF hz 0 Maf (GM/SE0.00)
app % 0
coolant C 83
intake air C 38
disired idle 600
TDC OFFSET -6.0
act timing 11.4
fuel rate (mm3) 0.0 (NO MAF?)
fuel temp C 41
crank ref missed 0
cam ref missed 0
inj close (ms) 1.67

PCM IN VTD FAIL YES
engine load% 1
cyl air (g/cyl)0.250
des cyl air g/c 35

still strange the maf is 0.00,
its got 5 volt between + and -
and a low resitant between maf and pcm

so i think the maf is dead (not so expensive as a ip)
i will look for a new one, I mean its the same as a petrol engine..
 

·
6.5TD Post Addict
Joined
·
9,886 Posts
The - 6 for TDCO is a product of the domestic cartridge you are using.
I have 2 OBD II cartidge's and use the latest model 1 when dealing with 6.5's.

The 2001 works best for me-if yours stops at 98 you are stuck with what you have.

I would concentrate on checking vacuum lines and vacuum strength at the wategate actuator and the wastegate/boost solenoid-I suspect a bad boost solenoid or broken vac line causing little to no boost from the turbo when you get the black smoke situation.

I would also consider trying a known working PMD with resistor installed.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #24 (Edited)
THANKS :thumb:

I think i go try a new PMD,
does the pcm needs the maf evenso?
or is the maf only for egr? by the chevy's

a broken vac line can be the problem for the dark smoke,
but not the rough idle.
 

·
6.5TD Post Addict
Joined
·
9,886 Posts
Well there may also be a problem with your ground circuits that could explain it all.

Check the 3 ground wires at the passenger side rear of the engine for clean secure connections.

However failing flight systems PMD's can also explain the mulitiiple problems.

And yes the ECM does need to see the maf signal-I am concerned about your scan tool interfacing properly with the older calibration module you are using.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #26
waiting for the pmd now:mad:
 

·
Registered
Joined
·
34 Posts
Discussion Starter #28
Thanks :thumb:

and if I right, its te same as a 1996-2000 patrol engines....




does engines without a EGR evenso have a MAF:think:
 

·
Premium Member
Joined
·
9,478 Posts
Thanks :thumb:

and if I right, its te same as a 1996-2000 patrol engines....
According to what I see on Rockauto.com it is the same for diesel and petrol engines.


does engines without a EGR evenso have a MAF:think:
According to what I see on Rockauto.com there is a Mass Air Flow sensor listed for the 1998 2500 (3/4 ton) series diesels, but not listed for the 1998 3500 (1 ton) series diesels.

Hopefully some one who has one of the 3/4 and 1 ton trucks will clarify this for you.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #30
Haha I've looked on rockauto to
 

·
Registered
Joined
·
34 Posts
Discussion Starter #32
not my lucky day, todat :banghead:

first a broke my intake manifold
after get a another one,
i will try if he wil run with the new pdm,
but before i can do i broke my starter :banghead::banghead::banghead::banghead::banghead:
 

·
Registered
Joined
·
34 Posts
Discussion Starter #35
:eek: broken the oil pressure switch too

I've borrowed a starter,
so i can test the pdm
and.....:bawl::bawl::bawl::bawl::bawl:

not good,
BUT I've got maf signal now!!!
so i test the old pdm, and even maf signal :wtf:

test drive and read for codes
next codes now:
P0113 IAT signal high
P0118 Coolant signal high
P0183 Fuel temperature sensor high
P0263 Cilinder 1 balance system
P0266 Cilinder 2 balance system
P0269 Cilinder 3 balance system
P0272 Cilinder 4 balance system
p0275 cilinder 5 balance system

ive got change the fuel filter......


looked at the data of the coolant-, fuel-, intake-, temp, everything seems te be normal....


will a new pump help me out of this:confuzeld
or must i looking for a bad wiring or something?:confuzeld:confuzeld


:help:
 

·
Premium Member
Joined
·
9,478 Posts
or must i looking for a bad wiring or something?:confuzeld:confuzeld

:help:
Thoroughly clean your grounds. Use this to help locate them: Importance of Good Grounds

Carefully check all of the wiring in the engine area. Look for loose connectors, frayed wires exposing the copper strands.

Make sure the PMD harness ground wire is securely attached to the top of the Injection Pump. See this picture:

_Ds4 IP 2.jpg
 

·
Registered
Joined
·
34 Posts
Discussion Starter #37
PMD ground check,
grounds on engine intake check (intake changed)
wires looked good and connectors, I can checked them good without the intake,

i think (or I hope a lot, or hope more, that i now think) its something like wires,
because now the maf has some signal...
 

·
Registered
Joined
·
34 Posts
Discussion Starter #38
btw there is no resistor in my PDM....
 

·
Administrator
Joined
·
16,040 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #40
But since i have the car, there never Be a resistor in it, (i have it 3 weeks)
 
21 - 40 of 51 Posts
Top