Diesel Place banner

1 - 20 of 42 Posts

·
Registered
Joined
·
340 Posts
Discussion Starter #1
Dont know if anyone else has recieved their stealth or not but it kicks a_ _ !!!! I was about to go postal when the mail man (sorry,"mail person")
showed up 3 hours later than usual. But about 10 min after signing for the package and give him a hug
I was up and running. I have only used the 70hp and it screaches my 325's going into second. Im giddy for the next 3 levels!!!
I will report as I try each one, just wanted to drop a quick post before I go looking for some rice burners, I mean for a drive!


Any way, I want everyone to report on their quad and how everything went with the transaction.


Wanna give a thanks to the guys at Quad and especially to Van!!!



Thanks,


Mike
Edited by: bybycop
 

·
Registered
Joined
·
3,410 Posts
What about me?
I told you it was sweet
 

·
Registered
Joined
·
340 Posts
Discussion Starter #3
HDMAX I do owe you a great big
!!! I will admit that you were the deciding factor in that decision! Thanks for your advise and posted stats! I cant believe that I could leave someone so important out of the picture! Im sorry!



How long do you think I should drive in the 70hp setting to break it in. I only have 3000 mi on my truck.


Thanks,


Mike
 

·
Registered
Joined
·
414 Posts
Van said mine went in the mail today. Can't wait...


Thanks,


Tim
 

·
Registered
Joined
·
340 Posts
Discussion Starter #5
K, Tried the 90 hp setting and boy does it light them up! I cant tell you how much fun it is. I also started a savings acount yesturday for a new set of tires.
Highly recomend everyone doing so. Im going to play with the tire resize feature today and check it with the GPS.


Tim, good luck. You should get it by the weekend wont ya?





Mike
 

·
Registered
Joined
·
3,410 Posts
mike; what GPS do you have? I just picked up the earthmate gps yesterday. it seems to worl pretty good for a hundred bucks. I will be trying it with Rand Mcnally street finder, I do not care for DeLorme.





I would say drive a few hundred miles on each setting if you can. And don't baby it all the time, or it will not help working up the ladder of power.
 

·
Registered
Joined
·
97 Posts
Got mine today. Have only used level 1 (70HP) so far. Went for a short drive after I got it at work (truck had just been driven 55 miles) and could notice a difference but didn't think it was all that great.


On the way home, went WOT at about 50mph and it really woke up! Almost seemed to be surging ahead at times. Backed off at 100mph and took it easy for remainder of the drive except for one other burst.


The power is definately there more quickly, even in level 1. Doesn't seem quite as linear as stock but not really concerned about that.


Shipping was the best I've ever seen to Canada.


So where do I buy Z rated tires with load range E?
 

·
Registered
Joined
·
7,187 Posts
HDLD said:
Got mine today. Have only used level 1 (70HP) so far. Went for a short drive after I got it at work (truck had just been driven 55 miles) and could notice a difference but didn't think it was all that great.


On the way home, went WOT at about 50mph and it really woke up! Almost seemed to be surging ahead at times. Backed off at 100mph and took it easy for remainder of the drive except for one other burst.


The power is definately there more quickly, even in level 1. Doesn't seem quite as linear as stock but not really concerned about that.


Shipping was the best I've ever seen to Canada.


So where do I buy Z rated tires with load range E?




I would give the truck time to adjust to the new power.


Update us in a few hundred miles, I'll bet you'll be surprised.


T
NY


 

·
Registered
Joined
·
6 Posts
I received my stealth yesterday and have put approx 300 miles on.


First, let me say that this is in my work truck, a 3500 dually with an enclosed utility body loaded with tools. I'm not looking to race or break any land speed records, just to improve responsiveness of the go pedal, (all work and no play...
), as well as retain day to day drivability. That said:


I plugged in and set the tune to the 110hp level, started the truck and found a perfect stock-like idle, as smooth and quiet as before the tune. I drove a day with the truck which consisted of approx 40 miles backroad/city and 120 miles hwy. Throttle response is fantastic! There's a big improvement in the low end, and it pulls hard to redline. On the hwy the cruise works perfectly and it seems to effortlessly maintain speed on uphill grades. I am very pleased and have noticed no negative aspects. I currently have no pyrometer but plan on installing one to monitor temps.


I briefly tried the 70 and 90 tunes today. Both seemed to lack the low end responsiveness of the 110 (although the 90 felt close). I plan on running the 70 until I get my pyro installed then keeping the 110 tune in semi-permanently.


About the group buy:


This was a great deal and I'd like to say Van has earned a repeat customer. I received the Quad in 2 days, It was packed well and contained invoices, decals and return policy, Very professional.


My .02
 

·
Registered
Joined
·
1,505 Posts
You guys are making me jealous. I sent my money order on Sat and still waiting. Should have had paypal I guess but I'll just have to wait patiently.


Edited by: Minn-Kota
 

·
Registered
Joined
·
196 Posts
Picked up my box today from the post office after missing the mail lady yesterday
. Threw it on the 70 hp setting (I have the 110hp box) right away. Definitely noticed the difference right away. The tach seemed to go buck wild through the gears. Really didn't help that when I was doing this there was concrete rubble flying around in the bed.


Don't know how smart this was for the first day having the chip but couldn't resist taking it to the track. I live 10 minutes from Englishtown Raceway Park in NJ so what the h . Went with my girlfriend
with the VW TDI. Safe to say we were the only diesels there.


Don't make fun of my times because this was my first time. Run motorcycles before but never cars. Left the line with no boost and got 15.92 @ 85.60 mph w/ a 2.44s 60'. That was with the 70 hp tune. Next run I got talked into running the 90 hp. Ran a 16.48 @ 86.77 mph w/ a 2.93 60'
. Left with 1200 rpm, truck started hopping, let off peddle, it was terrible.


Had a lot of fun. I can see how people get addicted to this. Prob be back next week.



Big thanks to Mike and Van!


Oh yeah. Have to tow a 7,000lb trailer tomorrow. Is it safe to use 40 hp setting (No gauges yet)? Couple of nice long grades on the pull. Think I saw a post that said temps would be no prob.
 

·
Registered
Joined
·
97 Posts
About 150 miles on mine so far. Fully warmed up, entering highway from onramp, 3 lanes. Right was clear, center had a vehicle up ahead and a RAM coming up and left was clear. About 1/2 throttle at entry. Noticed RAM was speeding up to close the gap in the middle lane instead of moving over. Went WOT (Level 1, 70 HP, limiter disabled) and moved right over (very safely) and into the fast lane. Only then did he move over, proceeding to ram up my A** but a few seconds later it was over when he hit his governor. I let off at 110mph.


Traffic later allowed him to catch up but he always stayed way back. Sheesh. If it's that easy to get a little respect then so be it!


I have noticed one thing. Don't know if it is a tuning anomoly or something that will settle down in time. At 2500RPM there is a very marked cyclical surging for a couple of seconds, on and off. Doesn't go away. It's a very steady pattern. You can hear it in the exhaust as well. As if you are adding some pedal but the RPM indicator isn't showing any change. About 2550 RPM IIRC.


Too chicken to try any other levels without guages.


Also looking into a Suncoast Stage II while the clutch packs are still pristine.
 

·
Registered
Joined
·
7,187 Posts
HDLD said:
About 150 miles on mine so far. Fully warmed up, entering highway from onramp, 3 lanes. Right was clear, center had a vehicle up ahead and a RAM coming up and left was clear. About 1/2 throttle at entry. Noticed RAM was speeding up to close the gap in the middle lane instead of moving over. Went WOT (Level 1, 70 HP, limiter disabled) and moved right over (very safely) and into the fast lane. Only then did he move over, proceeding to ram up my A** but a few seconds later it was over when he hit his governor. I let off at 110mph.


Traffic later allowed him to catch up but he always stayed way back. Sheesh. If it's that easy to get a little respect then so be it!


I have noticed one thing. Don't know if it is a tuning anomoly or something that will settle down in time. At 2500RPM there is a very marked cyclical surging for a couple of seconds, on and off. Doesn't go away. It's a very steady pattern. You can hear it in the exhaust as well. As if you are adding some pedal but the RPM indicator isn't showing any change. About 2550 RPM IIRC.


Too chicken to try any other levels without guages.


Also looking into a Suncoast Stage II while the clutch packs are still pristine.




Sounds like Fish Bite to me............


Maybe Quad can explain it.........I will leave it to him.


T
NY
 

·
Registered
Joined
·
1,505 Posts
QUOTE=GMC-2002-Dmax]


Sounds like Fish Bite to me............


Maybe Quad can explain it.........I will leave it to him.


T
NY








what are you saying by Fish Bite?Edited by: Minn-Kota
 

·
Registered
Joined
·
7,187 Posts
Minn-Kota,


Fish Bite was a common occurance with the first Edge Juice modules for the Duramax. Some trucks experienced it while others did not.


As far as I know it feels like a Fish nibbling on a line, hence the phrase "FISH BITE".


I never experienced it personally on my truck, but Mackin or others here that Beta tested the Juice can tell ya stories.


I would not worry about it, it could be a learning curve for your truck, hard to say..............


Keep us informed , just enjoy the power. Don't let your face freeze with that big grin either.


Good Luck .


T
NY
 

·
Registered
Joined
·
1,505 Posts
Ah. I see. First I've heard of that.


I don't have the programmer yet, but it's enroute I'm told and getting ancy. Edited by: Minn-Kota
 

·
Registered
Joined
·
97 Posts
From what I know of fish bite, it's like a fish nibbling but with no sounds. With mine, at 2500rpm (which of course is where the pilot injection cuts out) I can hear it in the engine and the exhaust. The pattern is like it is surging, then normal, then surging again, etc. It's not cutting out. I would interpret this to almost be like the opposite of fish bite, but that's just my guess.


This was right after taking it to 110mph. Not sure if that's related but it didn't go away during periodic testing over the next 20 miles or so. It was there on the way home as well but more subtle. I had been taking it easy on the way home.


Since new, 11 months ago, I have only filled at 2 stations, both with Sunoco Gold Diesel and I believe both are relatively high volume. Fuel filter was last changed about 8k mi. ago IIRC.


Anyway, will keep a fuel filter handy just in case and in the meantime continue monitoring. If it's tune related with no harm, then I'm not concerned as I don't normally drive above 2-2200.Edited by: HDLD
 

·
Registered
Joined
·
1,505 Posts
Finally, the mailman has brought my new toy.



Had some difficulty getting it to download the power program until I figured out that when it says turn the key to "on", it means "run" and not the first position forward. duh.


Recal'd the speedo for my 265's and verified with GPS and got it fine tuned.


Tried the 50, 70, and 90 tunes. Haven't ventured over the century mark yet. Awaiting gauges that should be arriving mid-week.
Probably even shouldn't be running the 70 without them to be on the safe side, but had to try it a little and all I can say is wow.


First tuner I've had and never rode in a diesel that had any sort of add-on so I was quite pleased. Moves out like a SOB from 30-80. Can hear the tires gripping all the way and begging for mercy. Seems to go pretty good after it hits 3rd and then put the hammer down with 80mph coming up quick. The 1-2 and 2-3 shifts are a little harsh yet. Hopefully some Alli education will smooth those out a little so I don't feel so tentative getting on it from stop or slower speeds. Bangs pretty hard.


As it is my first tuner, is it normal for these higher than stock tunes to cause the engine to "rattle" more? Sounds like rattlesnake under the hood when under slight to moderate acceleration. Seems almost like a gasser knocking in sound. Little rougher sounding than the factory tune under accel. I'm assuming this is due to some timing and/or the added fuel. Normal?? Virgin power user here, give me some guidance!


Anyway, it is so far so good and pleased as punch. Hope to get some gauges in this week as well as get some more miles on to smooth out the shifting a little.





Thanks to the GP organizer and vendor!
Edited by: Minn-Kota
 

·
Registered
Joined
·
414 Posts
Got my Stealth 135 box Thursday and tried it out over the weekend.


I have not tried the 135 setting, but I have used the other 3 (70, 90, & 110). I don't care for the 70 or 90 settings (so far). They don't seem to do much until about 1800rpm and then the throttle didn't feel linear anymore. Keep in mind I have the ZF6 tranny and the Allison.


In the 110 setting, a whole different story! I like it! It's like a whole different truck all the way from idle at 700. Went to lunch yesterday with some of my buds, and they asked me what I did to my truck since it would easily put you back in your seat with the go-pedal. Now if I only dared to try the 135 setting...


I don't have gauges, and I wasn't originally planning on getting them since I don't want to alert the stealer to an aftermarket box (what other reason would anyone add gauges they would ask?), but I am thinking I had better do it before I melt the turbine. I also have stock exhaust but at least it's early '02 w/o EGR and no cat in the path. I don't pull anything generally, just back and forth to work and West Texas/New Mexico highway driving once a month or so...


The thing that really bothers me about adding gauges is the drilling of the hole in the exhaust manifold. That just seems prone to problems to me. Is there any other method to get a fairly accurate EGT reading w/o doing this? How does the ECM monitor EGT's? Or doesn't it?


I like the Stealth box and I would recommend it to anyone who has a stock truck who wants more power.


Thank you Mike for putting the group buy together. Thank you Van for a great product at a great price.


Thanks,
Tim
 

·
Registered
Joined
·
105 Posts
I've had mine for a few days. I can honestly say that everything Minn-Kota said is true for me.( even the key to run thing
) All in all i'm happy. I don't have gauges and haven't tried anything more than the lowest setting but I like what I've felt so far,
 
1 - 20 of 42 Posts
Top