Diesel Place banner

1 - 12 of 12 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter #1
First time this happen, radio & the clock reset itself. Now not sure if this had anything to do with it but I tell you all the conditions. It poured today and I really mean poured. I got out of the truck to get a pack of smokes. I was out of the truck about 20 mins. I don't smoke in the truck thats about how long I was out of it. I had the radio on XM and the clock was set to the correct time. I drove home whick is only 3 blocks from the store and I was on the cell phone so I wasn't paying attention to the radio. when I got of the phone I heard static from the radio so I look and it was on FM and some station. Then I looked at the clock and the clock read 12:18. So this make me wonder what happen. Could this be a bad connection on the main power feed on the starter? Bad radio?
 

·
Registered
Joined
·
16,610 Posts
It doesn't sound like a bad power connection because even if the radio is completely removed from the truck it still retains the station memories just not the clock. IIRC. So sounds like a bad radio. I'd wait till it happens again because when you go to the dealer they will likely tell you that they can not duplicate the problem.
 

·
Registered
Joined
·
73 Posts
On another note...


I've been sitting on this for a while because it is minor but I finally got my truck serviced for the cracked right side mirror (regular heated ones), and asked the guy to take at a look at the radio (regular one) as it has always sounded bassy (sp?). Of course I got the sheet after a few hours and he wrote that he turned the bass down. I spent some time with him looking at it and he said he did notice that the later GM trucks are coming through with too much bass. Anyone else think so? I think it's defeinitely off from my other trucks..





Thanks
 

·
Registered
Joined
·
463 Posts
Leatherman said:
First time this happen, radio & the clock reset itself. Now not sure if this had anything to do with it but I tell you all the conditions. It poured today and I really mean poured. I got out of the truck to get a pack of smokes. I was out of the truck about 20 mins. I don't smoke in the truck thats about how long I was out of it. I had the radio on XM and the clock was set to the correct time. I drove home whick is only 3 blocks from the store and I was on the cell phone so I wasn't paying attention to the radio. when I got of the phone I heard static from the radio so I look and it was on FM and some station. Then I looked at the clock and the clock read 12:18. So this make me wonder what happen. Could this be a bad connection on the main power feed on the starter? Bad radio?




Dude! That's the "Missing Time" phenomenon!
What seemed like only 20 minutes to you, was in fact 3-1/2 hours!













































You were abducted by ALIENS!!!!!


Check your body for small, metallic implants...They are known to cause radio receivers to change frequency, and sometimes, even to change bands!


The worst part.........................They'll be back!









Kevin
 

·
Registered
Joined
·
169 Posts
My Radio some times will loose all the info after I turn it off and come back later to go somewhere I have to reset everything. I can live with it but it is a PITA
to have to hunt down all my info again. is this the same alien phenomenon?????
 

·
Registered
Joined
·
463 Posts
AkDually61 said:
My Radio some times will loose all the info after I turn it off and come back later to go somewhere I have to reset everything. I can live with it but it is a PITA
to have to hunt down all my info again. is this the same alien phenomenon?????




Yup!


You too have been "visited"!
 

·
Registered
Joined
·
463 Posts
I removed the radio from my truck when I installed my DVD system and I didn't loose any presets. Just the clock, like Max said.








Kevin
 

·
Registered
Joined
·
126 Posts
Discussion Starter #8
Ok it happen again tonight and I just lost the clock. All presets were ok. It was raining heavy again. So I really think it's a power problem. I am going to look at the starter wires tomorrow. I have heard of them being loose also glow plug light goes out way to fast. I have only seen it for seconds. I know the temps are up a little (40's) but it should stay on for a few seconds. Never seen it that fast before on other diesels.
 

·
Registered
Joined
·
570 Posts
Leatherman said:
Ok it happen again tonight and I just lost the clock. All presets were ok. It was raining heavy again. So I really think it's a power problem. I am going to look at the starter wires tomorrow. I have heard of them being loose also glow plug light goes out way to fast. I have only seen it for seconds. I know the temps are up a little (40's) but it should stay on for a few seconds. Never seen it that fast before on other diesels.

My glow plug light is on less than a second and sometimes when warm it won't come on at all. My stereo has jumped stations twice and the steering wheel controls will not work unless I change the presets on the unit itself then all is fine. Edited by: Voodoo
 

·
Registered
Joined
·
1,360 Posts
Don't think your glow plug cycle time has anything to do with it. The LLY has a new glow plug system installed on it and you should probably never see it on for more than maybe three seconds or so.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #11
ok I wasn't sure I know it's a fast system from what I have read
 

·
Registered
Joined
·
233 Posts
Leatherman said:
First time this happen, radio & the clock reset itself. Now not sure if this had anything to do with it but I tell you all the conditions. It poured today and I really mean poured. I got out of the truck to get a pack of smokes. I was out of the truck about 20 mins. I don't smoke in the truck thats about how long I was out of it. I had the radio on XM and the clock was set to the correct time. I drove home whick is only 3 blocks from the store and I was on the cell phone so I wasn't paying attention to the radio. when I got of the phone I heard static from the radio so I look and it was on FM and some station. Then I looked at the clock and the clock read 12:18. So this make me wonder what happen. Could this be a bad connection on the main power feed on the starter? Bad radio?

The radio in my '03 GMC started doing the same thing about 5 days after I took delivery of the truck. After having to reset the clock about 6 times
, I went back to the stealer. The SM put a Tech 2 on the truck and did some kind of reflash. That took care of the problem. I never had the problem again.
 
1 - 12 of 12 Posts
Top