Diesel Place banner

1 - 4 of 4 Posts

·
Registered
Joined
·
140 Posts
Discussion Starter #1
UPLOADED MY NEW PRED TODAY PUT THE 85 HP IN 1ST! THE TRUCK HAULED SOME SERIOUS #SS I COULDNT BELIEVE IT I DROVE AROUND MUCH OF THE DAY DIDNT HAVE ONE SEL LIGHT, NO PROBLEMS. THE ALLI WAS SHIFTING ROUGH AND OFF TIME MY ERT'S WERE FINE W/85HP AS FAR AS HOTRODDING AROUND TOWN NEVER GOT OVER 600DEG . ALLI STARTED GETTING BETTER ON THE WAY HOME.I DECIDED TO INSTALL THE 40HP TUNE. WOW IT WAS GREAT ALOT SMOOTHER THE 85HP BUT STILL LOTS OF POWER VERY NOTICABLE OVER STOCK! FOR ME ITS JUST FINE UNLESS I HAPPEN TO PULL NEXT TO A FORD WOULD LOVE TO LEAVE ONE IN THE DUST ON THE 85HP HAAAA!
ANYWAY SO FAR I AM VERY HAPPY WITH THE PREDATOR . I WILL TRY THE 65HP SOON. THE LIVE DIAGNOSTICS WERE VERY COOL AS WELL MY INJECTERS SEEM IN GREAT SHAPE ALL WERE .04 AT IDLE THEY ALL STAYED VERY CLOSE TO EACHOTHER WHEN I TOOK A GLIMSE WHILE DRIVING!
THOUGHT I'D GIVE MY 2CENTS
 

·
Registered
Joined
·
140 Posts
Discussion Starter #2
CAN ANYONE TELL ME APPROX HOW MANY MILES IT TOOK FOR THE ALLISON TO FIGURE OUT HOW TO HANDLE THE EXTRA PONEYS AND SHIFT NORMAL AGAIN? IT SEEMS TO BE BETTER BUT STILL ACTS WEIRD ON THE HIGHER HP TUNE.
 

·
Registered
Joined
·
12,004 Posts
600*? Something is wrong with your pyro...





I can get 600* without any real acceleration...900 comes stock on WOT. 1100 comes on the 85 HP mode WOT.
 

·
Registered
Joined
·
514 Posts
Pre or post turbo pyro? 600 sounds INCREDIBLY low for pre-turbo egt on the 85 HP. I'm on the 60HP and I rarely see anything that low if I'm mashing on it much at all.
 
1 - 4 of 4 Posts
Top