Diesel Place banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
This is the problem i have....


this morning when i went to upload a 60hp tune into the dmax, i got to 100% and then it gave me a communication error.....i tried to upload it again, and it says it cannot communicate with the pcm...i tried several times to do anything with it, but it kept asking me if my ignition was on/ communication error... so i started my truck and noticed the fuel gague was inop, and the info center was cycling between: the battery, security, and low fuel. i immediately noticed the truck had taken the tune...but it never had me cycle the ignition key..etc. to complete it. as i was driving i also noticed the coolant gauge never moved. I tried to get dtc's from the predator, but it could never communicate with the pcm. later today i noticed several times the coolant temp and the fuel gauge would restore to normal, but i still had the battery/security message on the info center. periodically the gauges would come on/go off.


i looked into the installed tune on the programmer and it said i had stock programming...so it never registered the vehicle took a tune.


after consulting diablosport's tech dept. he told me to try to have the pcm reflashed. i went to the dealer and they tried, but said they could not communicate with the pcm and it would not take a reflashing. they said all the wiring harness looked good, possibly a bad pcm.


the only thing i can think of while i was loading it i accidently had the daytime running lights on and it caused it to mess something up.


where do i start???
 

·
Registered
Joined
·
2,333 Posts
You need to talk with Diablo Sport again, I would say they need to help you get the problem resolved. I have never had mine do that, but I have had communication problems before and just started over and worked fine. Try unhooking your battery and leave it unhooked for a little while and hook it back up and try again. Just an idea.
 

·
Registered
Joined
·
11,646 Posts
That sounds like an issue with the programmer. Will it let you restore the stock tune? If not, try and load another tune. Having the DRL's on will not hurt anything, the reason they have you turn everything off is to maintain battery voltage. Did you have any trouble before loading it?
 

·
Registered
Joined
·
12,262 Posts
First off what year truck ?? Second welcome to the DieselPlace ...


If it's a 01 there is a GM software reflash for scan tool comunication error ... This may or may not be part of the problem as I don't know if you have all current updates...


As Eric asked did you try and return to stock ?? That's the first thing you have to do ... The Predator retains a copy ...


Mac
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
i tried unhooking the battery....no help....


tried restoring a stock and performance tune....tool will not communicate with pcm


gm tried to reflash pcm...could not communicate with truck..its an 02 2500 D/A chev (and i have had it for over a year, and never had any problem)


diablosport said they can send me a new predator with a stock tune to upload to the pcm...but if the dealer cant even reflash the computer...than that makes me think the pcm in the truck is bad.


the predator does turn on when i plug it in and when i look into the menu...it says the factory tune is installed...but my truck has more power than before...


westers garage said he can fix my pcm for $125 with a reflash to a stock tune....so mabye diablosport will pay for this if we cant get it solved...


and finally, glad to be here...been looking for a while, took me a few months to register, and a few months to post....


thanks for all of your help
 

·
Registered
Joined
·
12,262 Posts
Sounds like you have a good handle on it ....


Have Diablo send you the tuner first incase the one you have is bad ....


Good luck


Mac
 
1 - 6 of 6 Posts
Top