Diesel Place banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey there........new to the sight and had a couple questions that I need answered from some of you experts.

I recently had a predator module installed in my 02 duramax, stomped on it to pass a vehicle and the motor pretty much lost power. I pulled over and realized that I no longer had my reverse gear and was stuck in 2nd, then the "check engine soon" light came on. I turned the truck off, after restart had all gears, but no power. I pulled the module off, took it for a test drive and the light went out and the truck had power and smooth shifts.

What do you suppose happened and did I do any serious damage?:(
 

·
Registered
Joined
·
3,653 Posts
Your tranny went into limp mode. Start saving for an upgrade and drop a power level untill then.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Sorry to bug you again, but I'm still hoping that I didn't do any serious damage........should I take my truck into the stealer and have them check it out???
 

·
Registered
Joined
·
3,653 Posts
It will have warmed the clutches a bit and mabey put hot spots on the steels but it will be fine as long as you drop the power level down. Now that its limped once it will get easier and easier to do with each limp. What level were you running in when this happened?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Accually I just had a stage 1 predator module hooked up, which doesn't allow for any type of settings. Unlike their NitroFlash unit.
 
1 - 6 of 6 Posts
Top