Diesel Place banner

1 - 4 of 4 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter #1
<TABLE id=HB_Mail_Container height="100%" cellSpacing=0 cellPadding=0 width="100%" border=0 UNABLE="on">
<T>
<TR height="100%" UNABLE="on" width="100%">
<TD id=HB_Focus_Element vAlign=top width="100%" background="" height=250 UNABLE="off">


i've had my 2001 2500HD D/A for about 2 weeks...bought it from a truck resale lot...ran great!


last week hit 40k and i took it to a nearby gmc dealer for service...next day wudn't start...had it towed to dlr...tuned out fuel guage is off a bit, and there was lees fuel than i thot i had...i READ just less than 1/4 tank...after talks with gm tech, they put 10gals in, primed it and have had no starting trbl since...drove it around on errands yesterday...no problems...this was this past friday...


ANYWAY, yesterday, saturday, i was on a toll road...the speed limit is 65, and i accelerated normally to that speed after the toll booth...at 65 i had a pwr loss, like a pause, and the SES lite came on...cudn't go faster than 65, and it got worse on the way home...no acceleration at all, and at one point i cudn't go faster than 30mph...


wud accerate SLOWLY thru the gears, but NO acceleration...if i step on the pedal, i get this pause...am taking back to the drl tomorrow, but wud like opinions from here...


any ideas? </TD></TR>
<TR UNABLE="on" hb_tag="1">
<TD style="FONT-SIZE: 1pt" height=1 UNABLE="on">
<DIV id=hotbar_promo></DIV></TD></TR></T></TABLE>
 

·
Registered
Joined
·
114 Posts
Discussion Starter #3
<TABLE id=HB_Mail_Container height="100%" cellSpacing=0 cellPadding=0 width="100%" border=0 UNABLE="on">
<T>
<TR height="100%" UNABLE="on" width="100%">
<TD id=HB_Focus_Element vAlign=top width="100%" background="" height=250 UNABLE="off">thanks for the info, max...they replaced the fuel filter when they did the 40k service...cud it have clogged up so quickly?...drove it less than 4 hours...</TD></TR>
<TR UNABLE="on" hb_tag="1">
<TD style="FONT-SIZE: 1pt" height=1 UNABLE="on">
<DIV id=hotbar_promo></DIV></TD></TR></T></TABLE>
 

·
Registered
Joined
·
12,262 Posts
You thru a SES (service engine soon) light .... This is the key to your problem and correction direction ...


We could spend all day guessing .... For instance it could be you don't have all the current ECM upgrades and maybe it's a mass air defuel problem ...


Bring it into the dealer for proper diagnose ...





Mac
 
1 - 4 of 4 Posts
Top