Diesel Place banner
1 - 10 of 10 Posts

·
Registered
Joined
·
668 Posts
Discussion Starter · #1 ·
:help2: Next available appt. at dealer "6 days," thought I would try to get some idea's and help here. It started back in Sept. Loping idle for a few days then it cleared up until last week. Only when warm, idle jumps up about 200 rpm then almost dies before "catching it's breath" then repeating. has not set CEL, I have no way to pull codes. New fuel filters have not helped! Runs great off idle and at speed. Fingers stick installed 9 mos ago, all connections soldered. Edge EZ seems to mask it somewhat, "I have it off now for dealer appt." (they have to redo a pinion seal) Plan "B" is trying to clean MAF with some brake parts spray. Anything else I can try "at home?"
 

·
Registered
Joined
·
82 Posts
Not sure what the problem is from the info you gave, but I wouldn't use brake cleaner. I've seen it destroy plastic parts.

A BETTER idea if you are intent on cleaning the MAF, actually use a MAF Sensor cleaning product. I saw it advertised made by CRC.
 

·
Registered
Joined
·
668 Posts
Discussion Starter · #3 ·
4 days and counting! Cleaning MAF seemed to help a little, pushed the problem up to engine "hot," no melt downs with the brake cleaner. Evaporates to quickly I guess. I pulled feed hose off of the lift pump, good flow, though not as strong from AUX tank. Are there any more sensors down stream on the intake?
 

·
Registered
Joined
·
668 Posts
Discussion Starter · #4 ·
So much for computer controlled! New pinion seal failed because of bad bearings? If so, how big of a deal is this to fix?
 

·
Registered
Joined
·
668 Posts
Discussion Starter · #5 ·
I'm in! (to the dealer) New pinion seal failed because of yoke? $340 part? Oh...kay. No word on idle surge yet!
 

·
Registered
Joined
·
668 Posts
Discussion Starter · #6 · (Edited)
The good, bad and ugly of it all

A shiney new yoke in the diff.($312.70 parts and labor) Update did not cure idle problem - road check, OK:muahaha:. New calibration to delay "engine coolant hot" telltale!:lol: S.O.B's. Also 2 updates for p0116, seemed a little woried about that. (never found the buried fingers stick I guess)
 

·
Registered
Joined
·
668 Posts
Discussion Starter · #7 ·
:rant: I'm not sure how to take the myriad of responses I've gotten from the techs on this issue. The quietness is deafening! :help:, :Nothing_f ,at this time!
 

·
Registered
Joined
·
668 Posts
Discussion Starter · #8 ·
Thanks to Eric at Merchant Automotive! Knew what it was before hookin up the T-2! That -:t Censored :banghead: :duh: :nutkick: :pshyco: :smashfrea :thumbsdow :cookoo: :cussing: :sheephump fuel regulator.
 

·
Registered
Joined
·
668 Posts
Discussion Starter · #9 ·
However I just installed the "twins" KD lift pump and my idle problem is GONE. What's a monger to do?
 

·
Registered
Joined
·
668 Posts
Discussion Starter · #10 ·
Make that 80% better idle. Will still need to replace FPCV!
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top