Diesel Place banner
1 - 12 of 12 Posts

· Registered
Joined
·
171 Posts
The owners manual advises below 0*F degrees. I've plugged mine in when it's gotten down to around 10*F and also haven't. It always starts without a problem!
 

· Registered
Joined
·
351 Posts
Below 0. The book states not to use the block heater above 32. Mine started at 8 below with no problem without the heater pluged in.
 

· Registered
Joined
·
351 Posts
I use mine all the time and 30 is the norm here right now.
 

· Registered
Joined
·
1,350 Posts
usually around 20 deg. for me if i remember!
 

· Registered
Joined
·
6,501 Posts
Below 0 degrees......Yes
0 to 32 degrees.......Ok, but not necessary
Above 32 degrees....No
 

· Registered
Joined
·
481 Posts

· Registered
Joined
·
11,134 Posts
Look in the manual. Its zip tied on the passenger side near the manifold if I can remember. Do a quick search here and you will find all the answers you need regarding this.

GM obviously put it in a place where it cannot be easily reached. It took me a few days to find it too.
 

· Registered
Joined
·
6,451 Posts
please tell me where this plug can be found myfriend and i both have 05s nether know
Go out to your truck and stick your head and arms into the passenger front wheelwell over the tire. Reaching down, pick up the bottom edge of the pastic wheel well liner behind the tire and just behind the axle - you'll find the cord folded up and tied to the frame rail.;)
 

· Registered
Joined
·
209 Posts
I wouldn't plug in unless it's below 20
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top