Diesel Place banner

1 - 8 of 8 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1 (Edited)
Ok guys I need help!!! My truck has developed a LOUD knock under load .At around 1000-2000 rpm it sounds like its trying to throw a rod or something. When the truck is idling in netural or park and reved you don't hear a thing. No white smoke either. I just changed the fuel filter about 200 miles ago. I don't know if it's just a coincidence, but I just put a afe stage 2 on and a mbrp down pipe on.The down pipe clamp is tight and the exhaust is not hitting anything.I have search other post and it looks like I might be losing some injectors. I search for codes with my PPE and it found ( NO CODES) which I know is not right. I have 8800 miles on the truck. Any help would be appreciated. Jake
 

·
Banned
Joined
·
6,540 Posts
but I just put a afe stage 2 on and a mbrp down pipe on.The down pipe clamp is tight and the exhaust is not hitting anything.
Look at your manifold. Sounds like an exhaust leak.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #3
Why would I not hear it when Im in park and rev the truck? Only under load.
 

·
Registered
Joined
·
1,979 Posts
when your truck is in park and you rev it up there is no load on the drivetrain. exhaust pressure under a load is always greater than when the motor is not loaded even though you may be at the same rpm and throttle position. Check all your electrical connections and inspect for an exhaust leak around the egr or manifold! hope this makes sense.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #6
I saw that post and that might be my problem.That manifold is so deep in there that is's hard to get a good look at. Im still at it though.
 

·
Registered
Joined
·
47 Posts
I had a very similar problem. The conditions for my knocking:

1. 185 degree operating temperature
2. Under load at low throttle, under 2K RPM
3. Only the first time in the day the truck was operated (strange but true)

Through reasoning and experimentation, I narrowed the knocking down to a fuel delivery issue, and found on this website that a new calibration was out. I took my truck into the dealer and had them reflash it - problem solved. Here's the thread that talks about the recailbration:

http://dieselplace.com/forum/showthread.php?t=59974&highlight=reflash
 
1 - 8 of 8 Posts
Top