Diesel Place banner

1 - 6 of 6 Posts

·
Registered
Joined
·
151 Posts
Discussion Starter #1
I have a 94 6.5 4x4 K-5 Blazer with 421k. A rebuildt Turbocharge and solenoid were installed at 286K. Now getting a bit of a hesitation on acceleration and after the initial pause - black exhaust.

I hae a new solenoid ordered. I notice that there is a lot of play in the bushing (i think) where the wastegate linkage hooks up with the turbocharger. Will this play cause this hesitation by not pulling the wastegate open to full??
 

·
Registered
Joined
·
2,991 Posts
The actuator pulls the actuator closed to build boost pressure. Exhaust will push the wastegate open and the WG Solenoid controls the vacuum supplied to the Actuator to maintain desired boost pressure.

If the actuator moves freely and the pot inside is not ruptured, its fine.
 

·
Registered
Joined
·
151 Posts
Discussion Starter #3
Texas Diesel Guy: Thanks for the info. With 421K on this Blazer 6.5, do you think I should replace the pot???
 

·
Registered
Joined
·
634 Posts
421K miles?? That is excellent and I'm very impressed!! Was the engine ever taken apart at all.
 

·
Registered
Joined
·
2,991 Posts
Texas Diesel Guy: Thanks for the info. With 421K on this Blazer 6.5, do you think I should replace the pot???
If you got money burning a hole in your pocket, go for it.

I would suggest checking it, its very easy to do. Make sure the engine is cool and off. Unplug the black/orange vacuum lines to the WG solenoid and put your finger on the end of the black line to block it off.
While your holding it, pull the actuator out and hold it for a few seconds. If the vacuum you developed just by pulling the actuator arm out pulls it closed again, then your's is fine. If it leaks off then pull the vacuum line off directly from the pot, plug it with your finger and test it again.
If it tests good this time then you have a leaking vacuum line. If it still tests bad then you need a new pot.
 

·
Registered
Joined
·
151 Posts
Discussion Starter #6
PFlorenzano: Engine is orginal as is the transmission. Only thing opened was the troque converter to the transmission was replaces early on. I run this on long trips mostly. set the cruise on 73 and go down a 4 lane highway. I guess that's what it was made for.
 
1 - 6 of 6 Posts
Top