Diesel Place banner
1 - 17 of 17 Posts

·
Registered
Joined
·
506 Posts
Discussion Starter · #1 ·
I wasn't going to change it now. I usaully change mine every 5000 miles, but since I had the new style filter I thought that I better put it on. Maybe this is normal but if this is 1950 miles, there is no way these things could go to 15k without being clogged. I was shocked at this. Does it seem a little dirty for 2k miles?
This is my first time with a photo... If you don't see it, I will try to find out why.
Kirk
 

Attachments

·
Registered
Joined
·
369 Posts
looks like you need to buy fuel someplace different, or add a fuel additive such as primrose if your not running anything. i have run mine 7000 miles and the media looked as good or better, and the can didnt have all that garbage in it.
 

·
Registered
Joined
·
9,642 Posts
From what I have seen in these filters, is 2 vertical black streaks, then black from the bottom up. This has been the case in my last 6-7 changes. This filter was run w/ 2% Filter Life remaining.
Here's one pic.
 

Attachments

·
Registered
Joined
·
4,140 Posts
The black stripes are normal. Look above them and you'll see the holes that the fuel enters from. Since the system is under a vacuum the fuel gets sucked into the media before gravity pulls it to the bottom.

duramax/a
Your filter would have lasted a lot longer before it needed changing.
 

·
Registered
Joined
·
90 Posts
Great photo, I had a filter plug up, so when I changed mine I did the same thing you did and cut it open. My filter looked the same plus I had chunks of rust. I changed it twice in about 4,000 miles and it was very clean. I think I got some fuel from the bottom of a bad station tank.
 

·
Vendor
Joined
·
9,677 Posts
Looks like a SERIOUS need for an additive to control moisture and eliminate corrosion...
 

·
Registered
Joined
·
506 Posts
Discussion Starter · #9 ·
Interesting Comments. I use a fuel additive on every tank. I wonder if my power service is not doing it's job. I have never had water in the separator. More comments please.
Kirk
 

·
Premium Member
Joined
·
908 Posts
change fuel stations.....never seen anything like that!!!
 

·
Registered
Joined
·
1,460 Posts
is that like rust in the can or is it just some sedimit
 

·
Registered
Joined
·
369 Posts
Interesting Comments. I use a fuel additive on every tank. I wonder if my power service is not doing it's job. I have never had water in the separator. More comments please.
Kirk
Do you use the same station all the time or a few different places??

living in florida i wouldnt think you would have the magnitude of moisture from condensation like i have here in NY. so your either geting crap fuel, or not enough additive, or your additive sucks. i dont know anything about about power service so i wont say its junk ot good, but i can say i use primrose and we get crazy temp swings around here often ( like my motor will have condesation all over it) and i have never had any water in the trap, or a can that looked all cruded up like yours and i ran 8000 miles on the last one, heres the pic.
 

Attachments

·
Registered
Joined
·
506 Posts
Discussion Starter · #13 ·
is that like rust in the can or is it just some sedimit
Those are rust stains. All fuel was purchased from my local Gate station.
gsxr1216 vbmenu_register("postmenu_902034", true);
Diesel Addict



Join Date: Sep 2003
Location: Rochester, NY
Posts: 295



Quote:
Originally Posted by duramax/a
Interesting Comments. I use a fuel additive on every tank. I wonder if my power service is not doing it's job. I have never had water in the separator. More comments please.
Kirk



Do you use the same station all the time or a few different places??

living in florida i wouldnt think you would have the magnitude of moisture from condensation like i have here in NY. so your either geting crap fuel, or not enough additive, or your additive sucks. i dont know anything about about power service so i wont say its junk ot good, but i can say i use primrose and we get crazy temp swings around here often ( like my motor will have condesation all over it) and i have never had any water in the trap, or a can that looked all cruded up like yours and i ran 8000 miles on the last one, heres the pic.
Attached Thumbnails

This can looks clean after 8k miles. I think that I should change stations.
 

·
Registered
Joined
·
64 Posts
Bad Fuel

Never Fuel up @ a station when there is a pumper filling the tanks.
It takes a good couple of hours for all the stirred up sediment to settle after refueling the station tanks. Even your newer stations will have this problem.
 

·
Registered
Joined
·
1,460 Posts
you must get a lot of moister in our tank for that to happen
 
1 - 17 of 17 Posts
Top