Diesel Place banner

1 - 9 of 9 Posts

·
Registered
Joined
·
782 Posts
Discussion Starter #1
I went to start my 2020 AT4 by OnStar app today, at an ambient temp of - 9c...

Got to the truck to find out if had not started and threw the P214E code. Called onstar and the diagnostics test failed all tests, likely due to a communication error they said.

I was able to start by key with no issue and it ran just fine.

Truck is a few days old with 800 km's on it. No accessories installed on it.

I cleared the code and she didn't come back on subsequent starts, but the engine was warm already. It's a manufacturer specific code and from what I read, possibly injector specific... But can't find anything definitive on it.

Will go to dealer, but was wondering if anyone's seen this before and if so, what the cause and repair was.
 

·
Registered
Joined
·
35 Posts
I do not have that code but have a P01D1 code and my 2019 which is one month old today with 1600 miles on it is in to replace an Injector in Cylinder 4.
 

·
Registered
Joined
·
35 Posts

·
Registered
Joined
·
2,512 Posts
P214E Code Description:
Is the fuel pump sometimes not priming when you turn the key to ON(II)? Start by measuring the fuel pressure.
 

·
Registered
Joined
·
2,819 Posts
P214E Code Description:
Is the fuel pump sometimes not priming when you turn the key to ON(II)? Start by measuring the fuel pressure.
P214E says 'reductant pump' current high (DEF pump) at the link suggested above.
 

·
Registered
Joined
·
2,819 Posts
I went to start my 2020 AT4 by OnStar app today, at an ambient temp of - 9c...

Got to the truck to find out if had not started and threw the P214E code. Called onstar and the diagnostics test failed all tests, likely due to a communication error they said.

I was able to start by key with no issue and it ran just fine.

Truck is a few days old with 800 km's on it. No accessories installed on it.

I cleared the code and she didn't come back on subsequent starts, but the engine was warm already. It's a manufacturer specific code and from what I read, possibly injector specific... But can't find anything definitive on it.

Will go to dealer, but was wondering if anyone's seen this before and if so, what the cause and repair was.
Remote start by fob or app won't work if there is a fault light.
 

·
Registered
Joined
·
782 Posts
Discussion Starter #7
I got a databuss based remote start with an app, which is a key type start...so it starts now, even with an error code, which I have seen only once.
 

·
Registered
Joined
·
2,512 Posts
I got a databuss based remote start with an app, which is a key type start...so it starts now, even with an error code, which I have seen only once.
What was the dealer fix for your code? At least you should have it documented by your dealer.
 

·
Registered
Joined
·
315 Posts
We have replaced a few DEF pumps on the ‘20’s, they come as part of the tank, nothing serviceable in them now like they used to be... and the part will likely be backordered to lower slabovia...
 
1 - 9 of 9 Posts
Top