Diesel Place banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
I need help.with 2016 LML. Fuel pump went out and dealership replace the fuel pump, injectors, fuel lines and cleaned out the tank.
Within a few days engine started running bad and code P2149 came on. I would pull over and kill engine and start it back up and everything ran well for a few miles and sometimes for couple hundred miles. It started getting closer with the missing. The truck did not have power. The dealership could not duplicate the problem so they supposedly contacted GM and they were told to replaced #2 & & 7 with new injectors with new wires for injectors #2 & 7.
It continued with the problem and got bad. They told me it would need a new ECM. I bought a GM ECM online and had a Chevy rep program the new one. it lasted for about 400 to 600 miles and started again...
What is the problem?
Thanks in advance
 

·
Administrator
Joined
·
16,000 Posts
Welcome to DieselPlace
I would start by inspecting all of your wiring harness for worn wire insulation, exposed wiring, corrosion, broken wires, etc..
 

·
Registered
Joined
·
2,837 Posts
P2149 is set when the ECM output driver circuit detects a short to power, short to ground or an open circuit on injector circuit group 2 (I'm gonna guess that's injector 2 and 7, given the instructions from GM.

Follow OkDually's advice to carefully go over harness.

Can you verify which positions they replaced the injectors and wiring (drivers side/passenger side and position numbers from front of engine?
 

·
Registered
Joined
·
2,532 Posts
Some testing information for you contained in the attachment.
 

Attachments

·
Registered
Joined
·
6 Posts
Discussion Starter #6
P2149 is set when the ECM output driver circuit detects a short to power, short to ground or an open circuit on injector circuit group 2 (I'm gonna guess that's injector 2 and 7, given the instructions from GM.

Follow OkDually's advice to carefully go over harness.

Can you verify which positions they replaced the injectors and wiring (drivers side/passenger side and position numbers from front of engine?
They replaced all injectors then a month later they replace wiring and injectors for 2 and 7. I looked and it appears that front drivers side looks new I will look on the other side to see if I can tell
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
P2149 is set when the ECM output driver circuit detects a short to power, short to ground or an open circuit on injector circuit group 2 (I'm gonna guess that's injector 2 and 7, given the instructions from GM.

Follow OkDually's advice to carefully go over harness.

Can you verify which positions they replaced the injectors and wiring (drivers side/passenger side and position numbers from front of engine?
I appreciate all your info. I found the problem, it was 3 wires in the bundle that goes across the top of the engine. The bundle was on the AC line that is coming off the compressor. The heat and rubbing went through the black wrap and the wiring insulation causing the wires to short to the AC line/ground and probably across each other....
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
They replaced all injectors then a month later they replace wiring and injectors for 2 and 7. I looked and it appears that front drivers side looks new I will look on the other side to see if I can tell
I appreciate all your info. I found the problem, it was 3 wires in the bundle that goes across the top of the engine. The bundle was on the AC line that is coming off the compressor. The heat and rubbing went through the black wrap and the wiring insulation causing the wires to short to the AC line/ground and probably across each other....
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
They replaced all injectors then a month later they replace wiring and injectors for 2 and 7. I looked and it appears that front drivers side looks new I will look on the other side to see if I can tell
I appreciate all your info. I found the problem, it was 3 wires in the bundle that goes across the top of the engine. The bundle was on the AC line that is coming off the compressor. The heat and rubbing went through the black wrap and the wiring insulation causing the wires to short to the AC line/ground and probably across each other....
 
1 - 9 of 9 Posts
Top