Diesel Place banner

1 - 20 of 28 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter #1
Hey guys

Just wondering if anyone has found why the truck is throwing this code ? I replaced the stick today and resoldered the wires, so im sure its not the stick. Ive had no problems now for allmost 10,000 miles. Theres not to much information to do a search on yet. Could the Egr blocker plate be leaking? Maybe its a bad MASSAIR or the EGR is sticking open. any info would help THANKS.
 

·
Registered
Joined
·
336 Posts
06lbz;1558751; said:
Hey guys

Just wondering if anyone has found why the truck is throwing this code ? I replaced the stick today and resoldered the wires, so im sure its not the stick. Ive had no problems now for allmost 10,000 miles. Theres not to much information to do a search on yet. Could the Egr blocker plate be leaking? Maybe its a bad MASSAIR or the EGR is sticking open. any info would help THANKS.
P0402= EGR Flow Excessive
Just a suggestion, try putting it back to stock, then see if the code comes back. If it does, I would say the egr valve is sticking open. A drivability symptom of low power and black smoke is a good indication of a stuck open egr valve. If the codes do not return then something happened to your mod.

As far as the finger stick and block set up, I don't know too much about it. Maybe some here who has done this mod to their truck can chime in.

Good Luck
 

·
Registered
Joined
·
155 Posts
Discussion Starter #3
I was thinking that the egr was stuck also. I was going to take the blocker plate off and remove the stick and see what happens.
I havent had any power loss at all predator is on the 85 setting?
 

·
Registered
Joined
·
336 Posts
I've had the same problem for months,this past weekend I removed the plate and stick and the codes are gone.And yes ,all my connections were good.At first I thought it was the EGR again since I have had it replaced before.I put the stick in over a year ago,I think that since the LBZ was new that maybe the circuit was not correct.I'm going to order a new one,maybe it will work.
 

·
Registered
Joined
·
296 Posts
EGR Valve need to be replaced and the temp sensor.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #6
MaxmumDuramax
Have you run into this problem before? What makes you think its the temp sensor?
 

·
Registered
Joined
·
296 Posts
Yeah about a couple of weeks ago after I installed my intake system.
 

·
Registered
Joined
·
4,051 Posts
Check the intake tract. Loose clamps and especially a loose resonator connection between the MAF sensor and the turbo seem to be the usual culprits. The code is telling you that too much air is bypassing the MAF sensor.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #9
Fingers
I checked it myself a few times and had it cheched out at a friends shop. They looked at the blocker plate and the solder on the stick.
Maybe the clamps are squeezing down in the intake to much creating an air leak. Can I drive the truck with this code Im going to upstate NY friday.
Thanks
 

·
Registered
Joined
·
4,051 Posts
No harm to the engine. If the leak is bad, it might run odd at times. The usual leak is the resonator (the do-hicky with 6.6 embossed on it) People seem to knock it loose when they put the plate it.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #11
Thanks Fingers checked that just a coulpe of minutes ago. Im just going to take the stick and plate out and see what happens. Talked to a friend at the dealer, and he said theres been a good amout of problems with the EGR valve. Its under warranty, he said bring it in and they'll replace it if the EGR is bad.
 

·
Registered
Joined
·
3,185 Posts
How long have you had the AFE stage 2?
Can't remember who but someone here reported a code throwing problem with this filter. You might try cleaning the MAF sensor of any oil accumulation (if any) and reinstalling the OEM filter.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #13
A BEAR
I've had the stage 2 set up for about 4 months now. What kind of specific cleaner would you use to clean the mass air?
Thanks
 

·
Registered
Joined
·
202 Posts
I have the same problem with the same codes..SES light came on before i put the predator in...Tech said remove the chip wait for the light to return and bring it in, its been a week with no chip and still no light??? Going back to stock after 120 hp really sucks, feels like a 98 powerstroke with a bad turbo.....Still waiting for the light to come on...1 week and counting.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #15
I'm going to clean the mass air tomorrow, and clear the code with the predator. I hope thats the problem. Let you know how I make out.:banghead:
 

·
Registered
Joined
·
3,185 Posts
You can get the cleaner at most auto parts stores. You might also try replugging the MAF plug and check the connection of the blue wire on the finger stick. It's a long shot but it beats going to the dealer. Good Luck!
 

·
Registered
Joined
·
155 Posts
Discussion Starter #17
I could'nt wait till tomorrow. I cleaned the mass air and cleared the code with the predator. I took the truck for a 25 mile ride and no SES on the dash, but for hell of it I checked for codes and P0402 popped up on the predator again but not on the dash. (WHATS THE DEAL). Is this normal for having a stick and egr blockoff plate. I never did a code check before, when I had no issues
so i dont know if this is normal. What do you guys think?
 

·
Registered
Joined
·
155 Posts
Discussion Starter #18
SES came back after 40 miles. Back to the drawing board.
 

·
Registered
Joined
·
3,185 Posts
A few reported the EGR valve going out even after the blocker plate install. It's possible they were on the way out before blocking. Never heard of one going out if blocked right away. If it's the EGR valve I would reinstall the blocker plate right after changing it before it has time to soot up again. Then it should last.
 

·
Registered
Joined
·
4,123 Posts
a bear;1567771; said:
A few reported the EGR valve going out even after the blocker plate install. It's possible they were on the way out before blocking. Never heard of one going out if blocked right away. If it's the EGR valve I would reinstall the blocker plate right after changing it before it has time to soot up again. Then it should last.
Wendy was blocked with less then 500 miles and I got the rotten 46c code :(
 
1 - 20 of 28 Posts
Top